MOODLE FAILS AFTER INSTALLATION

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MOODLE FAILS AFTER INSTALLATION

Postby wild007 » 03. August 2019 20:56

Dear Sirs,

I have installed the Moodle Latest Ver 3.7 using XAMPP Version: Apache/2.4.39 (Win64) OpenSSL/1.1.1c PHP/7.3.7 on Windows 10.

The installation of the MOODLE went all perfect, and after updating the Plugins during Installation Phase, it has asked to set up the user account and password. The information was all created and after sometime loading the page, it crashes and gives the Error "Localhost Redirected you many times, ERR_TOO_MANY_REDIRECTS".

Here is the apache error Logs report, please advise the easiest way to solve this problem as I am quite new to this and would like to explore the MOODLE options for teaching online to my students.


[Sun Aug 04 02:29:54.940009 2019] [ssl:warn] [pid 8324:tid 580] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Aug 04 02:29:55.060042 2019] [core:warn] [pid 8324:tid 580] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Aug 04 02:29:55.080049 2019] [ssl:warn] [pid 8324:tid 580] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Aug 04 02:29:55.180077 2019] [mpm_winnt:notice] [pid 8324:tid 580] AH00455: Apache/2.4.39 (Win64) OpenSSL/1.1.1c PHP/7.3.7 configured -- resuming normal operations
[Sun Aug 04 02:29:55.180077 2019] [mpm_winnt:notice] [pid 8324:tid 580] AH00456: Apache Lounge VC15 Server built: May 29 2019 11:22:50
[Sun Aug 04 02:29:55.180077 2019] [core:notice] [pid 8324:tid 580] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sun Aug 04 02:29:55.220228 2019] [mpm_winnt:notice] [pid 8324:tid 580] AH00418: Parent: Created child process 7436
[Sun Aug 04 02:29:56.274622 2019] [ssl:warn] [pid 7436:tid 592] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Aug 04 02:29:56.414650 2019] [ssl:warn] [pid 7436:tid 592] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Aug 04 02:29:56.518684 2019] [mpm_winnt:notice] [pid 7436:tid 592] AH00354: Child: Starting 150 worker threads.
[Sun Aug 04 02:36:23.823975 2019] [ssl:warn] [pid 1992:tid 624] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Aug 04 02:36:23.960013 2019] [core:warn] [pid 1992:tid 624] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Aug 04 02:36:23.972016 2019] [ssl:warn] [pid 1992:tid 624] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Aug 04 02:36:24.080051 2019] [mpm_winnt:notice] [pid 1992:tid 624] AH00455: Apache/2.4.39 (Win64) OpenSSL/1.1.1c PHP/7.3.7 configured -- resuming normal operations
[Sun Aug 04 02:36:24.080051 2019] [mpm_winnt:notice] [pid 1992:tid 624] AH00456: Apache Lounge VC15 Server built: May 29 2019 11:22:50
[Sun Aug 04 02:36:24.080051 2019] [core:notice] [pid 1992:tid 624] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sun Aug 04 02:36:24.116061 2019] [mpm_winnt:notice] [pid 1992:tid 624] AH00418: Parent: Created child process 7044
[Sun Aug 04 02:36:25.340446 2019] [ssl:warn] [pid 7044:tid 532] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Aug 04 02:36:25.488495 2019] [ssl:warn] [pid 7044:tid 532] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Sun Aug 04 02:36:25.600527 2019] [mpm_winnt:notice] [pid 7044:tid 532] AH00354: Child: Starting 150 worker threads.
[Sun Aug 04 02:45:33.152576 2019] [php7:notice] [pid 7044:tid 1916] [client ::1:51285] PHP Notice: Undefined variable: hassiteconfig in C:\\xampp\\htdocs\\moodle\\admin\\settings\\security.php on line 3, referer: http://localhost/moodle/admin/settings/



Your urgent replies with the required solutions will be greatly appreciated.
wild007
 
Posts: 1
Joined: 03. August 2019 20:43
XAMPP version: 7.3.7
Operating System: Windows 10

Re: MOODLE FAILS AFTER INSTALLATION

Postby Nobbie » 04. August 2019 11:00

I have no idea about Moodle, i even dont know what it is. You should ask in a Moodle Support Forum, this the Xampp for Windows forum and it does not look as this is a Xampp problem.

Anyway, you should also look into the access_log, it might give you a clue which part of Moodle is going wrong. There seems to be an endless redirect to localhost (mostly done in .htaccess file, but it also may be done in PHP scripts).

P.S.: I found this Video, looks very helpfully to me, you should edit the admin index.php and after then remove the session files, see Video https://youtu.be/GKa7g2CY7t4
For me it looks as a very bad bug in Moodle which is a followup of changing the Admin account.
Nobbie
 
Posts: 11148
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: Nobbie and 53 guests