Cannot get Apache to run suddenly

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Cannot get Apache to run suddenly

Postby stevehomer » 25. July 2019 14:34

I am stuck where to go with this. Happened after a couple of weeks of happy use. have tried changing ports but no good.

Error logs seem to show nothing and Window Events is a mystery to me.

14:37:03 [main] Initializing Control Panel
14:37:03 [main] Windows Version: Home 64-bit
14:37:03 [main] XAMPP Version: 5.6.40
14:37:03 [main] Control Panel Version: 3.2.3 [ Compiled: Mar 7th 2019 ]
14:37:03 [main] You are not running with administrator rights! This will work for
14:37:03 [main] most application stuff but whenever you do something with services
14:37:03 [main] there will be a security dialogue or things will break! So think
14:37:03 [main] about running this application with administrator rights!
14:37:03 [main] XAMPP Installation Directory: "c:\xampp\"
14:37:03 [main] Checking for prerequisites
14:37:04 [main] All prerequisites found
14:37:04 [main] Initializing Modules
14:37:04 [Apache] Initializing module...
14:37:04 [Apache] Checking for module existence...
14:37:04 [Apache] Checking for required tools...
14:37:04 [Apache] Checking for service (name="Apache2.4"): Service not installed
14:37:04 [Apache] Service Path: Service Not Installed
14:37:04 [Apache] Checking default ports...

... Mercury and Filezilla stuff

14:37:04 [Tomcat] Checking default ports...
14:37:04 [main] Enabling autostart for module "Apache"
14:37:04 [main] Enabling autostart for module "MySQL"
14:37:04 [main] Starting Check-Timer
14:37:04 [main] Control Panel Ready
14:37:05 [Apache] Autostart active: starting...
14:37:05 [Apache] Checking default ports...
14:37:05 [Apache] Attempting to start Apache app...
14:37:05 [Apache] Executing "c:\xampp\apache\bin\httpd.exe"
14:37:05 [Apache] Return code: 0
14:37:05 [mysql] Autostart active: starting...
14:37:05 [mysql] Checking default ports...
14:37:05 [mysql] Attempting to start MySQL app...
14:37:05 [mysql] Executing ""c:\xampp\mysql\bin\mysqld.exe" --defaults-file="c:\xampp\mysql\bin\my.ini" --standalone --console"
14:37:05 [mysql] Return code: 0
14:37:05 [Apache] Status change detected: running
14:37:05 [mysql] Status change detected: running
14:37:06 [Apache] Status change detected: stopped
14:37:06 [Apache] Error: Apache shutdown unexpectedly.
14:37:06 [Apache] This may be due to a blocked port, missing dependencies,
14:37:06 [Apache] improper privileges, a crash, or a shutdown by another method.
14:37:06 [Apache] Press the Logs button to view error logs and check
14:37:06 [Apache] the Windows Event Viewer for more clues
14:37:06 [Apache] If you need more help, copy and post this
14:37:06 [Apache] entire log window on the forums

Thanks for any pointers
stevehomer
 
Posts: 7
Joined: 19. May 2016 12:31
XAMPP version: 5.6.19
Operating System: Win 10

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 62 guests