Can't start Apache in Xampp on Windows 10 x64

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't start Apache in Xampp on Windows 10 x64

Postby Shadow41 » 15. June 2019 09:02

Hi,
I can't start Apache in Xampp on Windows 10 x64.

The error logs are these:
Code: Select all
10:06:56  [main]    Initializing Control Panel
10:06:56  [main]    Windows Version:  Home  64-bit
10:06:56  [main]    XAMPP Version: 7.3.6
10:06:56  [main]    Control Panel Version: 3.2.4  [ Compiled: Jun 5th 2019 ]
10:06:56  [main]    You are not running with administrator rights! This will work for
10:06:56  [main]    most application stuff but whenever you do something with services
10:06:56  [main]    there will be a security dialogue or things will break! So think
10:06:56  [main]    about running this application with administrator rights!
10:06:56  [main]    XAMPP Installation Directory: "c:\xampp\"
10:06:56  [main]    Checking for prerequisites
10:06:56  [main]    All prerequisites found
10:06:56  [main]    Initializing Modules
10:06:56  [Apache]    Problem detected!
10:06:56  [Apache]    Port 80 in use by "Unable to open process" with PID 17588!
10:06:56  [Apache]    Apache WILL NOT start without the configured ports free!
10:06:56  [Apache]    You need to uninstall/disable/reconfigure the blocking application
10:06:56  [Apache]    or reconfigure Apache and the Control Panel to listen on a different port
10:06:56  [Apache]    Problem detected!
10:06:56  [Apache]    Port 443 in use by "Unable to open process" with PID 17588!
10:06:56  [Apache]    Apache WILL NOT start without the configured ports free!
10:06:56  [Apache]    You need to uninstall/disable/reconfigure the blocking application
10:06:56  [Apache]    or reconfigure Apache and the Control Panel to listen on a different port
10:06:56  [main]    Starting Check-Timer
10:06:56  [main]    Control Panel Ready
10:07:54  [Apache]    Problem detected!
10:07:54  [Apache]    Port 80 in use by "Unable to open process" with PID 17588!
10:07:54  [Apache]    Apache WILL NOT start without the configured ports free!
10:07:54  [Apache]    You need to uninstall/disable/reconfigure the blocking application
10:07:54  [Apache]    or reconfigure Apache and the Control Panel to listen on a different port
10:07:54  [Apache]    Problem detected!
10:07:54  [Apache]    Port 443 in use by "Unable to open process" with PID 17588!
10:07:54  [Apache]    Apache WILL NOT start without the configured ports free!
10:07:54  [Apache]    You need to uninstall/disable/reconfigure the blocking application
10:07:54  [Apache]    or reconfigure Apache and the Control Panel to listen on a different port
10:07:54  [Apache]    Attempting to start Apache app...
10:07:54  [Apache]    Status change detected: running
10:07:55  [Apache]    Status change detected: stopped
10:07:55  [Apache]    Error: Apache shutdown unexpectedly.
10:07:55  [Apache]    This may be due to a blocked port, missing dependencies,
10:07:55  [Apache]    improper privileges, a crash, or a shutdown by another method.
10:07:55  [Apache]    Press the Logs button to view error logs and check
10:07:55  [Apache]    the Windows Event Viewer for more clues
10:07:55  [Apache]    If you need more help, copy and post this
10:07:55  [Apache]    entire log window on the forums


Can someone please help me to fix Apache in Xampp?
Shadow41
 
Posts: 2
Joined: 15. June 2019 08:51
XAMPP version: 7.3.6
Operating System: Windows 10

Re: Can't start Apache in Xampp on Windows 10 x64

Postby Nobbie » 15. June 2019 19:46

Seems as if you either already have another Apache running, or you already have running Apache from Xampp (you cannot start it twice).

What happens when you enter "http://localhost" into your browser?
Nobbie
 
Posts: 10984
Joined: 09. March 2008 13:04

Re: Can't start Apache in Xampp on Windows 10 x64

Postby Shadow41 » 18. June 2019 21:28

I get to a page called: "XAMPP Apache + MariaDB + PHP + Perl". Apache works now, today. Problem solved.
Shadow41
 
Posts: 2
Joined: 15. June 2019 08:51
XAMPP version: 7.3.6
Operating System: Windows 10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 78 guests