Apache Service detected with wrong path

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Service detected with wrong path

Postby Benstrocity » 24. May 2019 12:06

Hello,

I'm having issues starting Apache. I'm not having a port issue, the problem is that it's trying to start the httpd.exe file within my old wamp64 directory (which doesn't exist anymore). I can't figure out how to change this. Any assistance would be great.

6:02:48 AM [Apache] Apache Service detected with wrong path
6:02:48 AM [Apache] Change XAMPP Apache and Control Panel settings or
6:02:48 AM [Apache] Uninstall/disable the other service manually first
6:02:48 AM [Apache] Found Path: "c:\wamp64\bin\apache\apache2.4.35\bin\httpd.exe" -k runservice
6:02:48 AM [Apache] Expected Path: "e:\xampp\apache\bin\httpd.exe" -k runservice
Benstrocity
 
Posts: 2
Joined: 24. May 2019 12:04
XAMPP version: 7.3.5
Operating System: Windows 10 Pro

Re: Apache Service detected with wrong path

Postby Benstrocity » 24. May 2019 19:31

I found the issue. It had to do with an Apache service running from my old wamp64 application. The service was still running and had the path to the old directory. Deleting that service fixes the issue. See below for in depth instructions for the fix.

Start Services via Control Panel>Admin Tools (also with Ctrl+R and services.msc)

Look for Apache and mySQL services. Look at the patch indicated in the description
(right click on service then click on properties). Chances are that you have Apache
listed twice, one from your correct install and one from a previous install. Even if
you only see one, look at the path, chances are its from a previous install and causing
your install not to work. In either case, you need to delete those incorrect services.

a. Got to command prompt (run as administrator): Start > all programs > Accessories >
right click on Command Prompt > Select 'run as administrator'

b. on command prompt type sc delete service, where service is the service you're wanting to delete,
such as apache2.1 (or sc delete Apache2.4). It should be exactly as it appears in your services.
If the service has spaces such as apache 2.1 then enter it in quotes, i.e. sc delete "apache 2.1"

c. press enter. Now refresh or close/open your services window and you'll see its gone.
Benstrocity
 
Posts: 2
Joined: 24. May 2019 12:04
XAMPP version: 7.3.5
Operating System: Windows 10 Pro


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests