ID doesn't match server name error AH01909

Problems with the Windows version of XAMPP, questions, comments, and anything related.

ID doesn't match server name error AH01909

Postby suehayden » 28. April 2019 20:40

Hi
Novice here, trying to install xampp 3.2.1.0 on Windows 10 Home 64-bit. Am using it for a MySQL class so downloaded the version recommended by the instructor xampp-win32-1.8.3-3-VC11-installer.exe from his website which has apparently worked successfully for lots of folks.
First, I had firewall issues, then http.sys issues -- corrected those with the advice from these boards.
Apache then started fine BUT as soon as I exited and tried to restart, no luck.
So I uninstalled, rebooted, etc etc.

The latest error log:

[Sun Apr 28 15:01:11.458215 2019] [mpm_winnt:notice] [pid 6600:tid 740] AH00455: Apache/2.4.7 (Win32) OpenSSL/1.0.1e PHP/5.5.9 configured -- resuming normal operations
[Sun Apr 28 15:01:11.458215 2019] [mpm_winnt:notice] [pid 6600:tid 740] AH00456: Apache Lounge VC11 Server built: Nov 21 2013 20:13:01
[Sun Apr 28 15:01:11.458215 2019] [core:notice] [pid 6600:tid 740] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sun Apr 28 15:01:11.458215 2019] [mpm_winnt:notice] [pid 6600:tid 740] AH00418: Parent: Created child process 13600
[Sun Apr 28 15:01:12.255048 2019] [ssl:warn] [pid 13600:tid 716] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Sun Apr 28 15:01:12.505051 2019] [ssl:warn] [pid 13600:tid 716] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Sun Apr 28 15:01:12.551932 2019] [mpm_winnt:crit] [pid 13600:tid 716] (OS 109)The pipe has been ended. : AH00404: Child: Unable to read socket data from parent
[Sun Apr 28 15:01:12.551932 2019] [mpm_winnt:crit] [pid 6600:tid 740] AH00427: Parent: child process 13600 exited with status 3 -- Aborting.

MySQL starts fine, but not Apache. Haven't been able to locate anything yet that applies to this exact problem.
Do I somehow still have a port conflict?
Any help would really be appreciated. :)
suehayden
 
Posts: 4
Joined: 28. April 2019 20:07
XAMPP version: 3.2.1.0
Operating System: Windows 10

Re: ID doesn't match server name error AH01909

Postby suehayden » 29. April 2019 16:04

Additional info: When I try to start Apache, the control panel shows PID as 15800. Then after a bit, it shows ports as 80, 443.
Then a quick flash on screen of another PID, not there long enough to be sure what it says but looks like 15400 or 15840. At that point, Apache errors out.
suehayden
 
Posts: 4
Joined: 28. April 2019 20:07
XAMPP version: 3.2.1.0
Operating System: Windows 10

Re: ID doesn't match server name error AH01909

Postby suehayden » 29. April 2019 17:09

Hi again - OK, completely uninstalled the version the instructor suggested (win32-1.8.3-3-VC11 etc) and took the download from ApacheFriends website xampp-windows-x64-7.3.4-0-VC15.installer.exe.

Control Panel V3.2.3
Get essentially the same error (different child process number):

[Mon Apr 29 12:05:11.052578 2019] [ssl:warn] [pid 27288:tid 656] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Apr 29 12:05:11.137279 2019] [ssl:warn] [pid 27288:tid 656] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Apr 29 12:05:11.184124 2019] [mpm_winnt:notice] [pid 27288:tid 656] AH00455: Apache/2.4.39 (Win64) OpenSSL/1.1.1b PHP/7.3.4 configured -- resuming normal operations
[Mon Apr 29 12:05:11.184124 2019] [mpm_winnt:notice] [pid 27288:tid 656] AH00456: Apache Lounge VC15 Server built: Mar 28 2019 11:59:33
[Mon Apr 29 12:05:11.184124 2019] [core:notice] [pid 27288:tid 656] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Mon Apr 29 12:05:11.199747 2019] [mpm_winnt:notice] [pid 27288:tid 656] AH00418: Parent: Created child process 24988
[Mon Apr 29 12:05:11.654337 2019] [ssl:warn] [pid 24988:tid 612] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Apr 29 12:05:11.739022 2019] [ssl:warn] [pid 24988:tid 612] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Mon Apr 29 12:05:11.785877 2019] [mpm_winnt:crit] [pid 24988:tid 612] (OS 109)The pipe has been ended. : AH00404: Child: Unable to read socket data from parent
[Mon Apr 29 12:05:11.785877 2019] [mpm_winnt:crit] [pid 27288:tid 656] AH00427: Parent: child process 24988 exited with status 3 -- Aborting.

Help please - I know very little about pc setup, or even basic DOS commands. If someone could just point me in a general direction.... I've scoured this board and can't find anything that works.
Thanks
suehayden
 
Posts: 4
Joined: 28. April 2019 20:07
XAMPP version: 3.2.1.0
Operating System: Windows 10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 69 guests