xampp and https://

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xampp and https://

Postby Sjor » 11. March 2019 09:31

Hi all,

I am desperately trying to make https work but can't make it. I have tried several manuals and combinations. I hope one of you pros can help me
I have XAMPP for Windows 7.1.4 on a Windows 10 Enterprise x64 system

I have created a project and actually put the main php files directly into the httpdocs folder.
my entry point is hostname.domain.com/main.php

After making everything run as supposed I wanted to activate https to keep my LDAP login attempts more secure.

I have created a certificate, I have tried editing the host, httpd.conf, httpd-ssl, httpd-vhosts, php.ini files with all the how to's you can find on google or StackOverflow.

can someone give me advice on why it's so hard for me to get https running?
Do I need to change my setup somehow?
Do I need to create a new project or can I get it running while being directly under c:\xampp\httdocs?

Greatest thanks for any feedback
Robert
Sjor
 
Posts: 1
Joined: 11. March 2019 08:59
XAMPP version: 7.1.4
Operating System: Windows 10 Enterprise

Re: xampp and https://

Postby Nobbie » 15. March 2019 13:05

It is definately impossible to give any hint without any knowledge about your configuration. I have no clue what you tried already.
Nobbie
 
Posts: 11044
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 66 guests