php disabled

Problems with the Windows version of XAMPP, questions, comments, and anything related.

php disabled

Postby Frederik Seyns » 04. October 2004 09:49

When I use XAMPP (version 1.4.9) as a localhost, everything is working fine. When I use it as a webserver, and I look at my status on remote, only https en ftp are activated.


MySQL database DEACTIVATED

PHP DEACTIVATED

HTTPS (SSL) ACTIVATED

Common Gateway Interface (CGI) DEACTIVATED

Server Side Includes (SSI) DEACTIVATED

SMTP Service DEACTIVATED

FTP Service ACTIVATED



Any idea what I need to do :?:

Thanks :!:
Frederik Seyns
 
Posts: 5
Joined: 01. October 2004 22:57

Postby Wiedmann » 04. October 2004 10:13

and I look at my status on remote,

/Remote/ is a pc on the internet and you access your server through a router?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Frederik Seyns » 04. October 2004 10:29

/remote/ is a computer at my school. I connect to my server via the IP. My server-comp is with a router, I've got some ports opened: port 80, 21 and one more (I'm at school, dont know the otherone by hart).
Frederik Seyns
 
Posts: 5
Joined: 01. October 2004 22:57

Postby Wiedmann » 04. October 2004 10:45

Ok, this is a little bug in the php code. The status page works only correct if you access it from the local network.

The page itself makes an accees to "http://%host_name-ip/testpage.php". But, you can not access your own server from lan via the public router ip. That's it.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 25 guests