port 80 used

Problems with the Windows version of XAMPP, questions, comments, and anything related.

port 80 used

Postby Fergie » 05. February 2019 19:01

Apache won't run because it can't access port 80, the program said to copy this message into the forum
Initializing Control Panel
11:49:16 AM [main] Windows Version: Enterprise 64-bit
11:49:16 AM [main] XAMPP Version: 7.3.1
11:49:16 AM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
11:49:16 AM [main] You are not running with administrator rights! This will work for
11:49:16 AM [main] most application stuff but whenever you do something with services
11:49:16 AM [main] there will be a security dialogue or things will break! So think
11:49:16 AM [main] about running this application with administrator rights!
11:49:16 AM [main] XAMPP Installation Directory: "c:\xampp\"
11:49:16 AM [main] Checking for prerequisites
11:49:26 AM [main] All prerequisites found
11:49:26 AM [main] Initializing Modules
11:49:26 AM [Apache] Problem detected!
11:49:26 AM [Apache] Port 80 in use by "Unable to open process" with PID 4!
11:49:26 AM [Apache] Apache WILL NOT start without the configured ports free!
11:49:26 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
11:49:26 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
11:49:26 AM [main] Starting Check-Timer
11:49:26 AM [main] Control Panel Ready
11:49:33 AM [Apache] Problem detected!
11:49:33 AM [Apache] Port 80 in use by "Unable to open process" with PID 4!
11:49:33 AM [Apache] Apache WILL NOT start without the configured ports free!
11:49:33 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
11:49:33 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
11:49:33 AM [Apache] Attempting to start Apache app...
11:49:33 AM [Apache] Status change detected: running
11:49:33 AM [mysql] Attempting to start MySQL app...
11:49:36 AM [filezilla] Attempting to start FileZilla app...
11:49:37 AM [mercury] Attempting to start Mercury app...
11:49:38 AM [Tomcat] Attempting to start Tomcat app...
11:49:38 AM [mysql] Status change detected: running
11:49:38 AM [filezilla] Status change detected: running
11:49:38 AM [mercury] Status change detected: running
11:49:41 AM [Apache] Status change detected: stopped
11:49:41 AM [Apache] Error: Apache shutdown unexpectedly.
11:49:41 AM [Apache] This may be due to a blocked port, missing dependencies,
11:49:41 AM [Apache] improper privileges, a crash, or a shutdown by another method.
11:49:41 AM [Apache] Press the Logs button to view error logs and check
11:49:41 AM [Apache] the Windows Event Viewer for more clues
11:49:41 AM [Apache] If you need more help, copy and post this
11:49:41 AM [Apache] entire log window on the forums
11:49:43 AM [Apache] Problem detected!
11:49:43 AM [Apache] Port 80 in use by "Unable to open process" with PID 4!
11:49:43 AM [Apache] Apache WILL NOT start without the configured ports free!
11:49:43 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
11:49:43 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
11:49:43 AM [Apache] Attempting to start Apache app...
11:49:43 AM [Apache] Status change detected: running
11:49:46 AM [Apache] Status change detected: stopped
11:49:46 AM [Apache] Error: Apache shutdown unexpectedly.
11:49:46 AM [Apache] This may be due to a blocked port, missing dependencies,
11:49:46 AM [Apache] improper privileges, a crash, or a shutdown by another method.
11:49:46 AM [Apache] Press the Logs button to view error logs and check
11:49:46 AM [Apache] the Windows Event Viewer for more clues
11:49:46 AM [Apache] If you need more help, copy and post this
11:49:46 AM [Apache] entire log window on the forums
11:50:03 AM [Tomcat] Status change detected: running
11:52:05 AM [Tomcat] Status change detected: stopped
11:52:05 AM [Tomcat] Error: Tomcat shutdown unexpectedly.
11:52:05 AM [Tomcat] This may be due to a blocked port, missing dependencies,
11:52:05 AM [Tomcat] improper privileges, a crash, or a shutdown by another method.
11:52:05 AM [Tomcat] Press the Logs button to view error logs and check
11:52:05 AM [Tomcat] the Windows Event Viewer for more clues
11:52:05 AM [Tomcat] If you need more help, copy and post this
11:52:05 AM [Tomcat] entire log window on the forums
11:52:05 AM [Tomcat] Tomcat Started/Stopped with errors, return code: 255
11:52:05 AM [Tomcat] Make sure you have Java JDK or JRE installed and the required ports are free
11:52:05 AM [Tomcat] Check the "/xampp/tomcat/logs" folder for more information
Fergie
 
Posts: 4
Joined: 05. February 2019 18:56
XAMPP version: 7.3.1
Operating System: Windows 10 Pro 64bit

Re: port 80 used

Postby Nobbie » 05. February 2019 22:24

Nobbie
 
Posts: 10987
Joined: 09. March 2008 13:04

Re: port 80 used

Postby Fergie » 06. February 2019 21:23

Thanks for the help. I got my port 80 problem solved.
Fergie
 
Posts: 4
Joined: 05. February 2019 18:56
XAMPP version: 7.3.1
Operating System: Windows 10 Pro 64bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 34 guests