OpenSSL searches for libeay32.dll and ssleay32.dll when it h

Problems with the Windows version of XAMPP, questions, comments, and anything related.

OpenSSL searches for libeay32.dll and ssleay32.dll when it h

Postby liubomirwm » 13. January 2019 14:02

Hello!
Since version 1.1.x OpenSSL releases use libcrypto-1_1-x64.dl and libssl-1_1.dll dlls instead of libeay32.dll and ssleay32.dll .For some reason OpenSSL continues to search for these two dlls and breaks with an error for missing them, although it has the libcrypto and libssl dlls.

A little background - i have a local development wordpress installation, and a plugin throws this exception:
Image

I use XAMPP with PHP 7.2.9 and OpenSSL 1.1.0i. When i go to directory C:\xampp\apache\bin and run the command below all is ok:
Image

This is the certificate that is server by the server. However, if i go into C:\xampp\php\extras\openssl i get this error:
Image
What makes me worry is the date of modification of the openssl.exe binary - 16th of April 2012. Maybe Apache has version 1.1.0i, but PHP has an older version? I do not know, XAMPP says that this version is released with OpenSSL 1.1.0i and if i open XAMPP's phpinfo page it says that the loaded module is OpenSSL 1.1.0i. However, they do update XAMPP regularly with new versions of openssl.

It should not be using an old binary, what do you think? I have also opened an issue on OpenSSL's GitHub:
https://github.com/openssl/openssl/issues/8011

If the images do not show fullscreen please right-click them and open them in a new tab.
liubomirwm
 
Posts: 1
Joined: 13. January 2019 13:46
XAMPP version: 7.2.9
Operating System: Windows 10

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 29 guests

cron