Page 1 of 1

Apache startup error..

PostPosted: 08. January 2019 01:41
by Saxondragon
First, thank you for taking the time to view this query. Your assistance is greatly appreciated.

I have been using xampp for years, with no issues.

System Information
OS Name Microsoft Windows 10 Home
Version 10.0.17134 Build 17134

Platform Role Desktop
Secure Boot State Off
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume2
Locale United States
Hardware Abstraction Layer Version = "10.0.17134.471"
User Name DESKTOP-OS4OKK0\James
Time Zone Eastern Standard Time
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 16.0 GB
Available Physical Memory 12.7 GB
Total Virtual Memory 18.3 GB
Available Virtual Memory 13.5 GB
Page File Space 2.38 GB
Page File C:\pagefile.sys

Xampp version V3.2.2 (compiled Nov 12, 2015)

Problem Background and context
Today I attempted to export a large table through php.admin and failed - the process got to 1.3 gigs and then I received a php timeout error.

I tried different settings with the php.ini file and still no joy. Each time with the same php timeout error. I shut down completely and then came back hours later when I had more time.

Now, Apache will not launch. I tried to run as administrator and received the same error.
The error is fairly generic and I see many instances of this on the forums:

Here are the latest logs.

7:22:43 PM [main] Initializing Control Panel
7:22:43 PM [main] Windows Version: Home 64-bit
7:22:43 PM [main] XAMPP Version: 5.6.31
7:22:43 PM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
7:22:43 PM [main] Running with Administrator rights - good!
7:22:43 PM [main] XAMPP Installation Directory: "e:\xampp\"
7:22:43 PM [main] Checking for prerequisites
7:22:43 PM [main] All prerequisites found
7:22:43 PM [main] Initializing Modules
7:22:43 PM [main] Starting Check-Timer
7:22:43 PM [main] Control Panel Ready
7:22:57 PM [mysql] Attempting to start MySQL app...
7:22:57 PM [mysql] Status change detected: running
7:23:01 PM [Apache] Attempting to start Apache app...
7:23:02 PM [Apache] Status change detected: running
7:23:02 PM [Apache] Status change detected: stopped
7:23:02 PM [Apache] Error: Apache shutdown unexpectedly.
7:23:02 PM [Apache] This may be due to a blocked port, missing dependencies,
7:23:02 PM [Apache] improper privileges, a crash, or a shutdown by another method.
7:23:02 PM [Apache] Press the Logs button to view error logs and check
7:23:02 PM [Apache] the Windows Event Viewer for more clues
7:23:02 PM [Apache] If you need more help, copy and post this
7:23:02 PM [Apache] entire log window on the forum

Here is the appache error log:
[Mon Jan 07 19:23:02.589965 2019] [ssl:warn] [pid 7820:tid 892] AH01909: server certificate does NOT include an ID which matches the server name
[Mon Jan 07 19:23:02.667656 2019] [core:warn] [pid 7820:tid 892] AH00098: pid file E:/xampp/apache/logs/ overwritten -- Unclean shutdown of previous Apache run?
[Mon Jan 07 19:23:02.670982 2019] [ssl:warn] [pid 7820:tid 892] AH01909: server certificate does NOT include an ID which matches the server name
PHP Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 341351 bytes) in Unknown on line 0

This appears to be the relevant event from Windows Event viewer:
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

I am loathe to reinstall. I am hoping that you folks with much more insight and experience than I, can educate me on how to most efficiently move forward.

Thank you,

-Jim aka Saxondragon

Re: Apache startup error..

PostPosted: 08. January 2019 09:54
by Nobbie
As you see, PHP runs out of memory. Increase memory_limit in php.ini and try again after restart of Apache.

If it keeps failing, dont use phpmyadmin, instead use mysqldump.exe from Mysql (its in the bin folder), which exports tables and databases directly from the database without the use of PHP. Here you will find the doc about it:

Re: Apache startup error..

PostPosted: 08. January 2019 12:34
by Saxondragon
Thank you for the reply.

Yes, your suggestion is correct for solving the underlying issue of exporting, but it had no effect on the problem of why Apache is failing on startup.

Current PHP memory limit set to 4096 megs.


Re: Apache startup error..

PostPosted: 08. January 2019 18:07
by Nobbie
For some reason, PHP tries to allocate memory directly after Apache hast started. I dont know why and where. Sorry, i have no clue what causes this behaviour. If i were you, i would try to to a full database backup with the help of mysqldump, then also backup the whole xampp folder - and finally de-install Xampp and install it again.

That sounds more harrassing as it is. Fortunately, Xampp installs quite easy. After re-installing it, import your databases and restore htdocs folder.

Anyway, i dont think that 4096M is a good value for memory_limit, because its an 32bit installation and in Windows32 a single process cannot exceed more than 2048M (even if 4096 is the theoretical highest value for a 32bit unsigned integer). Windows cannot assign more than 2048M to a single 32bit thread. Maybe this is already the reason for the startup error, before installing anything, simply try to run with a lower value, try 512M or so.

Re: Apache startup error..

PostPosted: 08. January 2019 18:13
by Altrea
i have heard about an issue in php which can produce such behavior if memory limit is set to exactly 4G.
just to proof that please set memory limit back to 1024M

Re: Apache startup error..

PostPosted: 08. January 2019 18:30
by Saxondragon
Very good. Thank you both kindly for your expertise and insight. It has been most helpful. I will lower the memory limit and then attempt the extractions.
That last piece on 32 bit memory limitation may be the root problem. That was something I did not know.

I lowered the memory limit as suggested to 1024 and Apache was able to launch.

Nicely done gentlemen. Thank you.

I can navigate the extraction from here using mysqldump.

Best regards,


Re: Apache startup error..

PostPosted: 08. January 2019 18:49
by Altrea
You are welcome :D