apache does not start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

apache does not start

Postby grdbum » 23. December 2018 01:45

I just installed XAMPP v3.2.2 on my HP Windows 7 laptop.

I am trying to get it so that Apache and MySQL start automatically.

This came up when I try to get it working. I am not a coder so this is all new to me. Please help me to get Apache and MySQL running.

Here are the messages I am getting.

Initializing Control Panel
5:13:14 PM [main] Windows Version: Windows 7 Home Premium SP1 64-bit
5:13:14 PM [main] XAMPP Version: 7.3.0
5:13:14 PM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
5:13:14 PM [main] You are not running with administrator rights! This will work for
5:13:14 PM [main] most application stuff but whenever you do something with services
5:13:14 PM [main] there will be a security dialogue or things will break! So think
5:13:14 PM [main] about running this application with administrator rights!
5:13:14 PM [main] XAMPP Installation Directory: "c:\xampp\"
5:13:14 PM [main] Checking for prerequisites
5:13:14 PM [main] All prerequisites found
5:13:14 PM [main] Initializing Modules
5:13:14 PM [Apache] Problem detected!
5:13:14 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
5:13:14 PM [Apache] Apache WILL NOT start without the configured ports free!
5:13:14 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:13:14 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:13:14 PM [mysql] XAMPP MySQL is already running on port 3306
5:13:14 PM [main] The FileZilla module is disabled
5:13:14 PM [main] The Mercury module is disabled
5:13:14 PM [main] The Tomcat module is disabled
5:13:14 PM [main] Enabling autostart for module "Apache"
5:13:14 PM [main] Enabling autostart for module "MySQL"
5:13:14 PM [main] Starting Check-Timer
5:13:14 PM [main] Control Panel Ready
5:13:15 PM [Apache] Autostart active: starting...
5:13:15 PM [Apache] Problem detected!
5:13:15 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
5:13:15 PM [Apache] Apache WILL NOT start without the configured ports free!
5:13:15 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:13:15 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:13:15 PM [Apache] Attempting to start Apache app...
5:13:15 PM [mysql] Autostart aborted: MySQL is already running
5:13:16 PM [Apache] Status change detected: running
5:13:16 PM [Apache] Status change detected: stopped
5:13:16 PM [Apache] Error: Apache shutdown unexpectedly.
5:13:16 PM [Apache] This may be due to a blocked port, missing dependencies,
5:13:16 PM [Apache] improper privileges, a crash, or a shutdown by another method.
5:13:16 PM [Apache] Press the Logs button to view error logs and check
5:13:16 PM [Apache] the Windows Event Viewer for more clues
5:13:16 PM [Apache] If you need more help, copy and post this
5:13:16 PM [Apache] entire log window on the forums
5:13:23 PM [main] Executing "services.msc"
5:16:26 PM [mysql] Attempting to stop MySQL app...
5:16:27 PM [mysql] Status change detected: stopped
5:17:55 PM [main] Executing "services.msc"
5:18:38 PM [Apache] Problem detected!
5:18:38 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
5:18:38 PM [Apache] Apache WILL NOT start without the configured ports free!
5:18:38 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:18:38 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:18:38 PM [Apache] Attempting to start Apache app...
5:18:38 PM [Apache] Status change detected: running
5:18:39 PM [Apache] Status change detected: stopped
5:18:39 PM [Apache] Error: Apache shutdown unexpectedly.
5:18:39 PM [Apache] This may be due to a blocked port, missing dependencies,
5:18:39 PM [Apache] improper privileges, a crash, or a shutdown by another method.
5:18:39 PM [Apache] Press the Logs button to view error logs and check
5:18:39 PM [Apache] the Windows Event Viewer for more clues
5:18:39 PM [Apache] If you need more help, copy and post this
5:18:39 PM [Apache] entire log window on the forums


Thank you for your assistance.
grdbum
 
Posts: 1
Joined: 23. December 2018 01:31
XAMPP version: v3.2.2
Operating System: Windows 7

Re: apache does not start

Postby vvucic » 23. December 2018 10:13

As you see it looks like that port 80 is blocked. Check your Firewall and read teh first post in this forum in which you will find procedures to diagnose issue.
vvucic
 
Posts: 20
Joined: 19. March 2009 00:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 106 guests