Site only approachable via local host

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Site only approachable via local host

Postby yearra » 02. December 2018 17:39

Hi All,

I am having an issue with my wordpress website.
The website is only approachable via my local host where this is hosted.
I have XAMPP Version 7.2.12 installed on my windows 10 pc.

I have followed a lot of manuals but it doesnt seem to solve my issue below:

Website is approachable when i type my domain on a browser on my local host. Example: www.example.com
But when I try to access it via a different pc, I receive a error 404.

What has been done:
Router has a port forward on, to the ip of my host.
Configured everything on Godaddy.com
HTTPD.conf is configured


Can someone help me?
I can get the site running on my ubuntu pc but the hardware is too slow to have a website running.
I would like to have it running on my windows pc.
yearra
 
Posts: 1
Joined: 28. November 2018 22:14
XAMPP version: 7.2.12
Operating System: Windows 10

Re: Site only approachable via local host

Postby Nobbie » 02. December 2018 21:16

When you installed WordPress, the installer asked for a ServerName. You only can run WordPress via using that ServerName. If you applied www.example.com, you must call it via www.example.com. If you try to run it via www.anotherexample.com or via 192.162.1.8 or any other IP, it fails.
Nobbie
 
Posts: 10670
Joined: 09. March 2008 13:04

Re: Site only approachable via local host

Postby kasemo » 18. December 2018 23:40

This isn't really an XAMPP/Apache issue. You have a routing issue.

It's one of two things:
A: The other PC doesn't know how to contact that system. ( Routes not set up )
B: Communications to that system are getting blocked. ( Firewall dropping communication. )

You need:
1) A DynDNS service + DynDNS client ( There are a number of services like this. I won't name any. You can find your pick by googling "dynamic dns service" )
2) Port forwarding on your firewall
3) Register that domain
4) Point its dns records to the dyndns records.

Tip: Make sure you attempt access from outside your local network. Use a VPN or some other connection to access & test.

Another option, is if you only need that site accessible internally you can hardcode its IP address into your hosts file.

( Try setting up with only the Apache "IT WORKS!" page. That will be easier than working with Wordpress to ensure you've got routes up good. )
kasemo
 
Posts: 5
Joined: 12. December 2018 16:17
XAMPP version: 7.2.3
Operating System: Windows 10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 90 guests