Can't install 1.4.8, "Can't find seachpath"

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't install 1.4.8, "Can't find seachpath"

Postby vigge89 » 01. October 2004 15:41

I've been using XAMPP for half a year now, and I haven't been experiencing any problems so far, but after I reformatted my computer two days ago, I can't install it anymore.

I've tried installing using both the setup and the 7-zip package, but none of them works. When i try installing using the setup, I get an error in the command-prompt appearing during the setup. "Can't find searchpath" or something ("Kan inte hitta sökvägen" on swedish), multiple times before the prompt disappears.

After the extraction, I run the setup_xampp.bat file, but it says that PHP cli can't be found and then stops. THis happens with both packages (setup/7-zip).

I've tried extracting the files to "D:\Server" & "D:\test" but none of them works. I used "J:\Server" before the formatting, and it worked perfect.

Any ideas or clues?
Thanks in advance, vigge.
vigge89
 
Posts: 8
Joined: 23. February 2004 11:31

Postby vigge89 » 01. October 2004 18:10

Here's how it looks like (Message highlighted is where something goes wrong i think :p )
Image
vigge89
 
Posts: 8
Joined: 23. February 2004 11:31

Postby Wiedmann » 02. October 2004 11:02

Hi vigge,

i have found this article in the Microsoft KB:
http://support.microsoft.com/default.as ... ;SV;311446

Maybe this is your problem...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby vigge89 » 02. October 2004 15:06

Hmm, doesn't look like it, I can run Exe-files, it's just something with apache/php I think. I've tried other server packages, but none of them worked either from what I have tested :(
vigge89
 
Posts: 8
Joined: 23. February 2004 11:31

Postby Wiedmann » 02. October 2004 15:14

You can run all new EXE-files you download?

It can be another virus... not only "SirCam". You have a virus scan installed? Try an online scanner.

You can use the tool "sfc.exe", to see if all Windows files are the correct version.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby vigge89 » 02. October 2004 15:20

yup, i've scanned the computer, no viruses :?
i'll check the sfc.exe out, thx for the tip :)
vigge89
 
Posts: 8
Joined: 23. February 2004 11:31

Postby vigge89 » 02. October 2004 16:48

ran SFC, nothing wrong there :?
vigge89
 
Posts: 8
Joined: 23. February 2004 11:31

Postby Wiedmann » 03. October 2004 00:08

Hi Vigge,

mysterious...

I've tried other server packages

What's the name of the other packages? Older XAMPP packages?

Another changes for you is to extract the ZIP in "C:\xampp" and use the server without "setup_xampp.bat".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby vigge89 » 03. October 2004 10:56

Apache2Triad, WAMP, EWS
i haven't really tried them out completly, i just installed them and tried to run them, didn't work on any package.

ill try the root-folder extracting :)

Edit: after extracting the xampplite zip into D:\xampplite, and then running apache_installservice.bat, gives this:
Installing apache2 as an server
Cannot find the searchpath.
Now we start apache2 :)
Incorrect servicename
(NET HELPMSG 2185)


I didn't run setup_xampp.bat

I tried execute the 'bin\apache -k install' in cmd.exe, after going to the D:\xampplite\apache folder, but it gave me this message:
"[Sun Oct 03 12:00:25 2004] [notice] Disabled use of AcceptEx() WinSock2 API"

I then started apache2 with "net start apache2"

apache seems to work now, but mysql doesn't
i can install the service, but after i've started mysql (net start mysql), it doesn't seem to start. if i try to load a php page with an mysql connection, it can't connect, and there's no mysql.exe in my tasklist :?
After starting mysql, if I stop it, cmd.exe says that it isn't running...
vigge89
 
Posts: 8
Joined: 23. February 2004 11:31

Postby vigge89 » 04. October 2004 16:17

tried the new 1.4.9 7-zip package, still no progress. Apache/Mysql/Bat-files can't find the paths to the different files :cry:
vigge89
 
Posts: 8
Joined: 23. February 2004 11:31


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests