Suddenly connecting to localhost doesn't work anymore

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Suddenly connecting to localhost doesn't work anymore

Postby freaky63 » 02. September 2018 09:34

Hey, yesterday I've been trying a install a few websites, everything was working just fine until suddenly no matter what's in the htdocs folder, I couldn't connect to my server anymore, nor localhost our outside local network.
I'm using a hoster so usually it's port forwarded. It just opens up www.localhost and tells me I can't connect to the server.
Firewall was deactivated of course, but that shouldn't be the matter if you connect from localhost anyways, right?

PC:
Win7 64-Bit
7.2.9-0 Xampp version

This is what I've been doing before:
- Changing modules for php and apache to install a certain website
- Giving writing perms to all files in the htdocs folder
- Tried a few different websites in the htdocs folder

This is what I've tried:
- Reinstalled Xampp
- Giving complete write perms to htdocs folder again
- tried http://127.0.0.1:80/ and it worked at first, now I try either localhost, 127.0.0.1, http:// with them or :Port on each (80 and 443) and nothing works

I'm completely clueless when it comes to apache and websites or any advanced coding as this is already way too confusing to me, especially because it happened all out of the sudden and reverting the changes I've applied doesn't seem to fix it.
Used the search function couldn't find any similar issue as well
freaky63
 
Posts: 3
Joined: 02. September 2018 09:23
XAMPP version: 7.2.9-0
Operating System: Win7 64-Bit

Re: Suddenly connecting to localhost doesn't work anymore

Postby freaky63 » 12. September 2018 17:23

Pushing this, any help would be apppreciated still dont know how to fix it
freaky63
 
Posts: 3
Joined: 02. September 2018 09:23
XAMPP version: 7.2.9-0
Operating System: Win7 64-Bit

Re: Suddenly connecting to localhost doesn't work anymore

Postby Nobbie » 12. September 2018 19:21

freaky63 wrote:I'm using a hoster so usually it's port forwarded.


That little sentence is so extremely super strange, at least here me and no one else have the slightest clue, what you are doing there. And what is the relationship to Xampp, Xampp does not need a hoster, Xampp does not need port forwarded to any hoster, it runs locally, extremey weird.. If you REALLY wants help, you have to explain BY FAR bettern than now. Currently i dont understand nothing.
Nobbie
 
Posts: 10546
Joined: 09. March 2008 13:04

Re: Suddenly connecting to localhost doesn't work anymore

Postby freaky63 » 15. September 2018 12:58

I mean, that was just some side information on what I was trying to do, I still described that I can't connect to my own website / localhost server via the browser. That's exactly whats wrong and I dont know how to explain it any better

Again then, I was trying to install some websites, after a few attempts, connecting to localhost doesn't work anymore. It just says "can't connect to server". I've been googling and for some other people using the port in localhost fixed it, so I tried 127.0.0.1:80 and it worked once, then I tried it again and it never worked again.
freaky63
 
Posts: 3
Joined: 02. September 2018 09:23
XAMPP version: 7.2.9-0
Operating System: Win7 64-Bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests