Apache Won't Start - Tried several workarounds but nothing

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Won't Start - Tried several workarounds but nothing

Postby bdups » 03. July 2018 14:07

Hello,

I have been using XAMPP for a long time, today I was developing a site and suddenly, simply out of the blue Apache and MySQL fell, both went offline. MySQL turned back on but Apache won't. start. ever.

Windows Event Logs states the classic as most problems:
The Apache service named reported the following error:
>>> (OS 10048)Normalmente é permitida apenas uma utilização de cada endereço de soquete (protocolo/endereço de rede/porta). : AH00072: make_sock: could not bind to address 0.0.0.0:80 .
The Apache service named reported the following error:
>>> AH00451: no listening sockets available, shutting down .

The Apache service named reported the following error:
>>> AH00015: Unable to open logs .


First try after running XAMPP yields a red message, the following tries only logs "Return code: 0".

09:51:09 [Apache] Checking default ports...
09:51:09 [Apache] Attempting to start Apache service...
09:51:09 [Apache] Executing "net start "Apache""
09:51:10 [Apache] Status change detected: running
09:51:11 [Apache] Status change detected: stopped
09:51:11 [Apache] Error: Apache shutdown unexpectedly.
09:51:11 [Apache] This may be due to a blocked port, missing dependencies,
09:51:11 [Apache] improper privileges, a crash, or a shutdown by another method.
09:51:11 [Apache] Press the Logs button to view error logs and check
09:51:11 [Apache] the Windows Event Viewer for more clues
09:51:11 [Apache] If you need more help, copy and post this
09:51:11 [Apache] entire log window on the forums
09:51:12 [Apache] Return code: 0
09:51:55 [main] Executing notepad.exe t:\xampp\apache/conf/extra/httpd-ssl.conf
09:52:07 [main] Executing "t:\xampp\"
09:52:57 [Apache] Checking default ports...
09:52:57 [Apache] Attempting to start Apache service...
09:52:57 [Apache] Executing "net start "Apache""
09:52:59 [Apache] Return code: 0
09:54:17 [Apache] Checking default ports...
09:54:17 [Apache] Attempting to start Apache service...
09:54:17 [Apache] Executing "net start "Apache""
09:54:20 [Apache] Return code: 0

1. Ran as admin
2. Check ports: I had already changed from port 80 when I installed, so I tried changing to yet another ports, but no success.
3. Check if any programs are using these ports and absolutely nothing was using those ports, not the old and not the new ones.
4. Tried checking IIS - wasn't even activated, then tried activating and same problem. Changed port to 80 and got unsolvable PID4 even with sticky FAQ, nothing solved.
5. Problem remains unfixed and unclear as to why it cannot listen to any ports.

Just what is going on? This is driving me mad. I was just finishing a site with absolutely no backups and I must find a way to fix this. :(
bdups
 
Posts: 1
Joined: 03. July 2018 13:57
XAMPP version: 7.2.2
Operating System: Windows 10

Re: Apache Won't Start - Tried several workarounds but nothi

Postby Nobbie » 03. July 2018 20:13

bdups wrote:I was just finishing a site with absolutely no backups and I must find a way to fix this. :(


Ouch!!!

First of all (first things first): DO A BACKUP! Copy the whole folder c:/xampp to an external disk or so. Dont try to run it, back it up!
When you are ready, we can go deeper.
Nobbie
 
Posts: 10343
Joined: 09. March 2008 13:04

Re: Apache Won't Start - Tried several workarounds but nothi

Postby tryah85 » 17. July 2018 22:46

Open the Apache config file config.conf, goto line ~215

Where:
DocumentRoot 'X:\XXXXXXXXXXXXXXXXXX'
<Directory "C:\XXXXXXXXXXXXXXXXXX">

Replace all Backspashes \ with Forwardspashes /. I had the same problem and this fixed it for me.


Unix vs Window paths
tryah85
 
Posts: 1
Joined: 17. July 2018 22:31
XAMPP version: 3.2.2
Operating System: Windows 10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 38 guests