Computers not seeing content on webpage

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Computers not seeing content on webpage

Postby tmanneri » 28. June 2018 01:40

So I am fairly new to xampp and I've managed to install it on my works server. This is acting as the local host for our intranet website. I have also managed to install wordpress as I will be using this to design the website. The problem I'm having is I can see all of the content I create in wordpress on the localhost:portnumber/wordpress but when I go to another machine at the office I have to type in the ip address of the server:portnumber/wordpress/wp_login. The browser gets redirected to the wordpress website but it doesn't display any of the content I put in on the server side. I have a feeling it's a file that isn't configured right but I can't seem to find any answers for this. :cry:
tmanneri
 
Posts: 1
Joined: 28. June 2018 01:33
XAMPP version: 3.2.2
Operating System: Windows Server 2012R2

Re: Computers not seeing content on webpage

Postby Altrea » 28. June 2018 12:01

Wordpress by default can only be used for one Domain/Host.
To use multiple Domains/Hosts you need to use Multisite or a workaround you can find with google (Wordpress configuration issues are out of scope of this supportr board here).
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Computers not seeing content on webpage

Postby TonyVier » 28. June 2018 16:35

tmanneri wrote:So I am fairly new to xampp and I've managed to install it on my works server. This is acting as the local host for our intranet website. I have also managed to install wordpress as I will be using this to design the website. The problem I'm having is I can see all of the content I create in wordpress on the localhost:portnumber/wordpress but when I go to another machine at the office I have to type in the ip address of the server:portnumber/wordpress/wp_login. The browser gets redirected to the wordpress website but it doesn't display any of the content I put in on the server side. I have a feeling it's a file that isn't configured right but I can't seem to find any answers for this. :cry:


Ok.

Best is to create a virtual host for your wordpress site. Give it the name of a subdomain of an existing website you own, something like intranet.example.com

Then go to your website provider, hope you have one and they allow DNS edits, and add this subdomain of the existing domain with the ip address of your local pc.

Then, everyone on the intranet can use your wordpress site.

Do it all the time, it works perfectly.

Don't hesitate to ask more.
TonyVier
 
Posts: 43
Joined: 24. May 2018 11:22
XAMPP version: 7.2.5-0
Operating System: Windows 10 pro

Re: Computers not seeing content on webpage

Postby Nobbie » 29. June 2018 09:21

but when I go to another machine at the office I have to type in the ip address of the server:portnumber/wordpress/wp_login.


You may also enter server:portnumber on localhost (simply enter the LAN IP instead of "localhost"), therefore you should have provided the LAN IP instead of "localhost" at installation of wordpress. Either de-install wordpress and install it again, this time apply the LAN IP as servername, OR simply edit wp-config.php and search the configuration of the local server and change "localhost" to the LAN IP of the server.

After that you can run wordpress from all your intranet PC as well from your server using the LAN IP (do not use "localhost" anymore).
Nobbie
 
Posts: 10510
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 72 guests