Startup of Tomcat Stalls with Command window open

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Startup of Tomcat Stalls with Command window open

Postby 63CentsADay » 28. April 2018 15:43

Hello,
I can't seem to get the Xampp Control Panel to indicate that Tomcat is running (even though it is)....
It hangs with a DOS command window open and the Start button never goes Green and turns to the Stop Button.
Here's the entire startup echo.....

Code: Select all
C:\xampp>cd c:\xampp\

C:\xampp>title c:\xampp\catalina_start.bat

C:\xampp>IF EXIST tomcat\logs\catalina.pid (del /F/Q tomcat\logs\catalina.pid )

C:\xampp>set TASKCMD=TASKLIST /V

C:\xampp>set FINDCMD=FIND /I

C:\xampp>FOR /F "tokens=2 delims= " %A IN ('TASKLIST /V | FIND /I "c:\xampp\catalina_start.bat"') DO SET MyPID=%A

C:\xampp>SET MyPID=3732

C:\xampp>echo.


C:\xampp>echo [XAMPP]: Searching for JDK or JRE HOME with reg query ...
[XAMPP]: Searching for JDK or JRE HOME with reg query ...

C:\xampp>set JDKKeyName64=HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit

C:\xampp>set JDKKeyName32=HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\JavaSoft\Java Development Kit

C:\xampp>set JREKeyName64=HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment

C:\xampp>set JREKeyName32=HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\JavaSoft\Java Runtime Environment

C:\xampp>reg query "HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit" /s
ERROR: The system was unable to find the specified registry key or value.

C:\xampp>if 1 EQU 1 (
echo . [XAMPP]: Could not find 32 bit or 64 bit JDK
 echo . [XAMPP]: Looking for 32 bit JDK on 64 bit machine
 goto FINDJDK32
)
. [XAMPP]: Could not find 32 bit or 64 bit JDK
. [XAMPP]: Looking for 32 bit JDK on 64 bit machine

C:\xampp>reg query "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\JavaSoft\Java Development Kit" /s
ERROR: The system was unable to find the specified registry key or value.

C:\xampp>if 1 EQU 1 (
echo . [XAMPP]: Could not find 32 bit JDK
 echo . [XAMPP]: Looking for 32 bit or 64 bit JRE
 goto FINDJRE64
)
. [XAMPP]: Could not find 32 bit JDK
. [XAMPP]: Looking for 32 bit or 64 bit JRE

C:\xampp>reg query "HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment" /s

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment
    CurrentVersion    REG_SZ    1.8
    BrowserJavaVersion    REG_SZ    13.0.1

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.8
    RuntimeLib    REG_SZ    C:\Program Files\Java\jre1.8.0_172\bin\server\jvm.dll
    JavaHome    REG_SZ    C:\Program Files\Java\jre1.8.0_172
    MicroVersion    REG_SZ    0

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.8.0_172
    JavaHome    REG_SZ    C:\Program Files\Java\jre1.8.0_172
    MicroVersion    REG_SZ    0
    RuntimeLib    REG_SZ    C:\Program Files\Java\jre1.8.0_172\bin\server\jvm.dll

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.8.0_172\MSI
    INSTALLDIR    REG_SZ    C:\Program Files\Java\jre1.8.0_172\
    JU    REG_SZ
    OEMUPDATE    REG_SZ
    FROMVERSION    REG_SZ    NA
    FROMVERSIONFULL    REG_SZ
    PRODUCTVERSION    REG_SZ    8.0.1720.11
    EULA    REG_SZ
    JAVAUPDATE    REG_SZ    1
    AUTOUPDATECHECK    REG_SZ    1
    AUTOUPDATEDELAY    REG_SZ
    FullVersion    REG_SZ    1.8.0_172-b11


C:\xampp>if 0 EQU 1 (
echo . [XAMPP]: Could not find 32 bit or 64 bit JRE
 echo . [XAMPP]: Looking for 32 bit JRE on 64 bit machine
 goto FINDJRE32
)

C:\xampp>set KeyName=HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment

C:\xampp>goto JRERUN

C:\xampp>echo.


C:\xampp>echo [XAMPP]: Using JRE
[XAMPP]: Using JRE

C:\xampp>set "CURRENT_DIR=C:\xampp"

C:\xampp>set "CATALINA_HOME=C:\xampp\tomcat"

C:\xampp>set Cmd=reg query "HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment" /s

C:\xampp>for /F "tokens=2*" %i in ('reg query "HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment" /s | find "JavaHome"') do set JRE_HOME=%j

C:\xampp>set JRE_HOME=C:\Program Files\Java\jre1.8.0_172

C:\xampp>set JRE_HOME=C:\Program Files\Java\jre1.8.0_172

C:\xampp>echo.


C:\xampp>echo [XAMPP]: Seems fine!
[XAMPP]: Seems fine!

C:\xampp>echo [XAMPP]: Set JRE_HOME : C:\Program Files\Java\jre1.8.0_172
[XAMPP]: Set JRE_HOME : C:\Program Files\Java\jre1.8.0_172

C:\xampp>echo [XAMPP]: Set CATALINA_HOME : C:\xampp\tomcat
[XAMPP]: Set CATALINA_HOME : C:\xampp\tomcat

C:\xampp>echo.


C:\xampp>if 0 == 0 (echo 3732  1>tomcat\logs\catalina.pid )

C:\xampp>"C:\xampp\tomcat\bin\catalina.bat" run
Using CATALINA_BASE:   "C:\xampp\tomcat"
Using CATALINA_HOME:   "C:\xampp\tomcat"
Using CATALINA_TMPDIR: "C:\xampp\tomcat\temp"
Using JRE_HOME:        "C:\Program Files\Java\jre1.8.0_172"
Using CLASSPATH:       "C:\xampp\tomcat\bin\bootstrap.jar;C:\xampp\tomcat\bin\tomcat-juli.jar"
Apr 28, 2018 10:36:49 AM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\Java\jre1.8.0_172\bin;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;"C:\Java\jdk\jdk-10.0.1\bin;C:\xampp\tomcat\;C:\Java\jre\jre1.8.0_172\";C:\Users\Hoopty\AppData\Local\Microsoft\WindowsApps;;.
Apr 28, 2018 10:36:49 AM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["http-bio-8888"]
Apr 28, 2018 10:36:49 AM org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["ajp-bio-8009"]
Apr 28, 2018 10:36:49 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 1115 ms
Apr 28, 2018 10:36:49 AM org.apache.catalina.core.StandardService startInternal
INFO: Starting service Catalina
Apr 28, 2018 10:36:49 AM org.apache.catalina.core.StandardEngine startInternal
INFO: Starting Servlet Engine: Apache Tomcat/7.0.56
Apr 28, 2018 10:36:49 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory C:\xampp\tomcat\webapps\docs
Apr 28, 2018 10:36:50 AM org.apache.catalina.util.SessionIdGenerator createSecureRandom
INFO: Creation of SecureRandom instance for session ID generation using [SHA1PRNG] took [110] milliseconds.
Apr 28, 2018 10:36:50 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deployment of web application directory C:\xampp\tomcat\webapps\docs has finished in 735 ms
Apr 28, 2018 10:36:50 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory C:\xampp\tomcat\webapps\examples
Apr 28, 2018 10:36:51 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deployment of web application directory C:\xampp\tomcat\webapps\examples has finished in 843 ms
Apr 28, 2018 10:36:51 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory C:\xampp\tomcat\webapps\host-manager
Apr 28, 2018 10:36:51 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deployment of web application directory C:\xampp\tomcat\webapps\host-manager has finished in 125 ms
Apr 28, 2018 10:36:51 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory C:\xampp\tomcat\webapps\manager
Apr 28, 2018 10:36:51 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deployment of web application directory C:\xampp\tomcat\webapps\manager has finished in 125 ms
Apr 28, 2018 10:36:51 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory C:\xampp\tomcat\webapps\ROOT
Apr 28, 2018 10:36:51 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deployment of web application directory C:\xampp\tomcat\webapps\ROOT has finished in 94 ms
Apr 28, 2018 10:36:51 AM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["http-bio-8888"]
Apr 28, 2018 10:36:51 AM org.apache.coyote.AbstractProtocol start
INFO: Starting ProtocolHandler ["ajp-bio-8009"]
Apr 28, 2018 10:36:51 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 2104 ms


At this point Tomcat is running, all three ports are showing up in Netstat as in use but the Start button never turns Green and never displays the word STOP

Can I please get suggestions?
Thanks
63CentsADay
 
Posts: 2
Joined: 28. April 2018 02:43
XAMPP version: 3.2.2
Operating System: Windows 10

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 145 guests