Can't find mod_perl

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't find mod_perl

Postby afmytwocents » 21. March 2018 20:03

I am trying to update a version of XAMPP 1.7.7 to 5.6.34. Someone else did the original install and used mod_perl.so. I cannot find the mod_perl.so in the 5.6.34 installation directory. My understanding is that it should be there. I also checked 7.x.x versions of XAMPP and it was not there either. The code uses Apache:ASP which I believe requires perl_mod - how can I get this upgrade working?
afmytwocents
 
Posts: 1
Joined: 21. March 2018 18:11
XAMPP version: 5.6.34
Operating System: Windows 2012 R2

Re: Can't find mod_perl

Postby Nobbie » 22. March 2018 03:36

afmytwocents wrote:My understanding is that it should be there. I also checked 7.x.x versions of XAMPP and it was not there either. The code uses Apache:ASP which I believe requires perl_mod - how can I get this upgrade working?


No. Xampp does not deliver mod perl.
Nobbie
 
Posts: 10089
Joined: 09. March 2008 13:04

Re: Can't find mod_perl

Postby gsmith » 26. March 2018 18:49

gsmith
 
Posts: 230
Joined: 29. November 2013 18:04
Location: San Diego
XAMPP version: 0.0.0
Operating System: Win 7-10/VS 6,9,11,14,15

Re: Can't find mod_perl

Postby BerryTaylor » 31. March 2018 21:27

Here is the link https://perl.apache.org/download/index.html where you can find mod-Perl.
BerryTaylor
 
Posts: 1
Joined: 31. March 2018 21:13
XAMPP version: 1.8.0
Operating System: Windows 7

Re: Can't find mod_perl

Postby gsmith » 07. April 2018 02:49

BerryTaylor wrote:Here is the link https://perl.apache.org/download/index.html where you can find mod-Perl.

Hmm, not very helpful unless you are looking for the source to compile yourself.

If you start there, click on Binary mod_perl distributions, then click on Win32 mod_perl 2.0 binary distributions, you end up at this page: https://perl.apache.org/docs/2.0/os/win ... e_packages

Now let's look at those choices.
IndigoPerl, the last version of it is based on Perl 5.10 and from 2009. Since Apache 2.4.0 didn't come out till 2012, any mod_perl in it is for Apache 2.2 and will not work with 2.4.

Next on the list is Xampp, we know that's a no go.

Then DeveloperSide.NET, their latest download has Apache 2.4.16 VC11 32bit, workable so far, could be loaded in any Apache 2.4 vc11-15, but there's no mod_perl.

That leaves zangweb, and that 404s.

Steve Hay is the one of the folks that got mod_perl working for Apache 2.4. He's one of the mod_perl dev's hence the people.apache.org url. The binaries are linked to Apache Lounge builds (what's in Xampp) and is the only option available today.
gsmith
 
Posts: 230
Joined: 29. November 2013 18:04
Location: San Diego
XAMPP version: 0.0.0
Operating System: Win 7-10/VS 6,9,11,14,15


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests