XAMPP install succes but can't get point to Joomla

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP install succes but can't get point to Joomla

Postby avandel » 19. February 2018 16:07

Hi,
I was hoping you guys can help me out. If I go to my website it goes automatically to \dashboard, while I have Joomla installed, I can't seem to find the right way to make my Joomla homepage show up as standard when someone enters my site by its name, it still goes to the XAMPP page.....

Where can I change this and why did it not activate by itself if i walked through the setup proces of XAMPP and then JOOMLA?

I hope someone can help me....

Thanks
avandel
 
Posts: 8
Joined: 19. February 2018 16:02
XAMPP version: 7.2.2
Operating System: windows server 2012 64bit

Re: XAMPP install succes but can't get point to Joomla

Postby avandel » 19. February 2018 18:36

I've been searching the web about this, but could not find a solution that would fit in the installation process. Just went to the XAMPP folder, deeper into HTDOCS, and opened index.php and changed there the only setting of the word dashboard in joomla...

On the bottom it says that there went something wrong with the installation, go figure....
How can I resolve this in a normal way?
avandel
 
Posts: 8
Joined: 19. February 2018 16:02
XAMPP version: 7.2.2
Operating System: windows server 2012 64bit

Re: XAMPP install succes but can't get point to Joomla

Postby Nobbie » 19. February 2018 20:12

Where did you install Joomla (into which folder)? Please apply the full pathname of your Joomla Installation (where is the index.php file from Joomla?).
Nobbie
 
Posts: 10227
Joined: 09. March 2008 13:04

Re: XAMPP install succes but can't get point to Joomla

Postby avandel » 19. February 2018 21:11

F:\xampp\apps\joomla\htdocs.... where it standard goes.... Index.php from joomla is in there...
avandel
 
Posts: 8
Joined: 19. February 2018 16:02
XAMPP version: 7.2.2
Operating System: windows server 2012 64bit

Re: XAMPP install succes but can't get point to Joomla

Postby Nobbie » 20. February 2018 13:02

Did you install Joomla from Bitnami? Because there is also "plain" Joomla in the Internet and i dont know which one you installed?! If you install Joomla from Bitnami, i think it should create an ALIAS or similar for accessing Joomla into your browser, you MUST NOT simply use localhost. Isnt there any documentation about running Joomla in Xampp?

I just entered "How to access Bitnami Joomla" and it leads me directly to a readme, which you should read before going any further: https://bitnami.com/stack/joomla/README.txt

Did you read that?
Nobbie
 
Posts: 10227
Joined: 09. March 2008 13:04

Re: XAMPP install succes but can't get point to Joomla

Postby avandel » 20. February 2018 16:15

Hi, thanks. I did read it, but no use for me, as I installed all through bitnami.
What also is solved is the manual change that I made in the index.php, not to let it point to dashboard, but to joomla.....
This action I took is ofcourse not the right one, as it calls the index.php in XAMPP and not in JOOMLA folder.... That is my question, how to correct that!
avandel
 
Posts: 8
Joined: 19. February 2018 16:02
XAMPP version: 7.2.2
Operating System: windows server 2012 64bit

Re: XAMPP install succes but can't get point to Joomla

Postby Nobbie » 20. February 2018 16:43

avandel wrote:Hi, thanks. I did read it, but no use for me, as I installed all through bitnami.


You did not read it, as IT IS FOR YOU, you MUST follow it IF YOU INSTALL THROUGH BITNAMI. It contains all answers to your questions.
Nobbie
 
Posts: 10227
Joined: 09. March 2008 13:04

Re: XAMPP install succes but can't get point to Joomla

Postby avandel » 20. February 2018 20:17

AH fuck it. I'll figure it out myself, not gonna write long words to tell you that I was not born yesterday, and I don't need a NOOB telling me that I did not read something, AS I DID!
Thanks for nothing. :|
avandel
 
Posts: 8
Joined: 19. February 2018 16:02
XAMPP version: 7.2.2
Operating System: windows server 2012 64bit

Re: XAMPP install succes but can't get point to Joomla

Postby Nobbie » 20. February 2018 22:38

You are simply lying and as long as you dont read that file, you wont succeed. Its on you. Its your problem, not mine.
Nobbie
 
Posts: 10227
Joined: 09. March 2008 13:04

Re: XAMPP install succes but can't get point to Joomla

Postby avandel » 20. February 2018 22:51

No Dobbie, you might think you are an Elf, but you are merely HUMAN!
Oh before I forget to say, I did read, I did follow the steps, and there was no problem installing, but as you being HUMAN, you can't look inside my world to see if I am lying or not. Oh and just to tell you, If you read the text 1000 times or more, then you would not come up with the answer, and that is:
In folder F:\xampp\apache\conf is a file named httpd.conf and in that file there is a line that tells where to go....
At line 247-248 it says
DocumentRoot "F:/XAMPP/htdocs"
<Directory "F:/XAMPP/htdocs">

and I changed that in

DocumentRoot "F:/XAMPP/apps/joomla/htdocs"
<Directory "F:/XAMPP/apps/joomla/htdocs">

All is well, thank you for fucking with me, it brought me where I wanted to be....
avandel
 
Posts: 8
Joined: 19. February 2018 16:02
XAMPP version: 7.2.2
Operating System: windows server 2012 64bit

Re: XAMPP install succes but can't get point to Joomla

Postby olivier » 21. February 2018 17:22

Hello,
For information, i had trouble with joomla and PHP 7.2. I had to downgrade to PHP 7.1 version to resolve my problems.
olivier
 
Posts: 1
Joined: 21. February 2018 17:17
XAMPP version: 7.1.14
Operating System: Windows

Re: XAMPP install succes but can't get point to Joomla

Postby avandel » 22. February 2018 08:14

On what platform did you install it? if I may ask....
The only little things I had was that FTP and HTTP was already active on IIS on my Windows 2012 server, but after disabling and shuttingdown of those resources (services.msc), I got a neat install...

Glad You found the problem and could solve it through smart thinking..... A pity actually that the automated process could not capture those problems for you....
avandel
 
Posts: 8
Joined: 19. February 2018 16:02
XAMPP version: 7.2.2
Operating System: windows server 2012 64bit

Re: XAMPP install succes but can't get point to Joomla

Postby Nobbie » 22. February 2018 11:50

avandel wrote:Glad You found the problem and could solve it through smart thinking.....


Funny. You simply destroyed your Xampp installation and cannot reach the dashboard anymore, instead of simply reading readme.txt and following that super simple advice:

And you can access the following URL on Windows:

http://127.0.0.1/joomla/


This does not work for you anymore and now you cannot reach the dashboard with all the usefull links (phpinfo etc.). Really smart....
Nobbie
 
Posts: 10227
Joined: 09. March 2008 13:04

Re: XAMPP install succes but can't get point to Joomla

Postby avandel » 22. February 2018 13:10

Noobie, instead of crappin' down people's neck you could be helpfull instead of saying BS.

I really can't see your point, I can touch my dashboard fine, it is within armlength if I sit in my car, or if I want to go remotely to my server, or adjust anything on my website.
So,.....
I really can't see your point.
avandel
 
Posts: 8
Joined: 19. February 2018 16:02
XAMPP version: 7.2.2
Operating System: windows server 2012 64bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 45 guests