Tomcat won't start - everything else works (Windows 10)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Tomcat won't start - everything else works (Windows 10)

Postby lisztv » 16. February 2018 05:07

Tomcat error message says that either Java is not installed or the port is not open as the cause of the error. However, I did install java and I assigned a new port number to tomcat.

Take a look below:

Image

Not sure if the link above will work. Here's another one:

Image

Also, the Tomcat log here is empty: C:\xampp\tomcat\logs

Please help. Thanks.
lisztv
 
Posts: 5
Joined: 16. February 2018 04:49
XAMPP version: 7.2.1
Operating System: Windows 10

Re: Tomcat won't start - everything else works (Windows 10)

Postby lisztv » 16. February 2018 09:27

My images above are not dipslaying....
The first one is from onedrive and the other from dropbox. Yes, I surrounded the link with the img pair and yes, onedrive and dropbox told me anyone who sees the link can view the pictures. So how come these images are not showing?

For dropbox the link was:
https://www.dropbox.com/s/nelnl2gzgihxfur/tomcat%20problem-small%20pix.png?dl=0

Image
lisztv
 
Posts: 5
Joined: 16. February 2018 04:49
XAMPP version: 7.2.1
Operating System: Windows 10

Re: Tomcat won't start - everything else works (Windows 10)

Postby Altrea » 16. February 2018 11:09

lisztv wrote:So how come these images are not showing?

Open your Browsers Web Developer Tools (commonly Key F12), go to the network tab (or something similar) and execute your "image" url and you will see, that there are many many requests fired for many many files. So that url does not contain true image stream data.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9202
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Tomcat won't start - everything else works (Windows 10)

Postby Nobbie » 16. February 2018 12:11

lisztv wrote:Tomcat error message says that either Java is not installed or the port is not open as the cause of the error. However, I did install java and I assigned a new port number to tomcat.


No, it does NOT say that Java is not installed. It says that JDK and JRE are missing, only "Java" is an insufficient description. Did you install a JDK and a JRE, and did you check if the run properly? JDK = Java Development Kit, JRE = Java Runtime Environment

Try to run Tomcat NOT(!) as a service, try to run it directly from the Xampp Controlcenter not as service. Also start the Xampp Controlcenter as Administrator (right click Xampp icon and choose "Run as Administrator...").

Finally, your "images" arent images, your links points to HTML pages which also contains images, but that is quite a different thing than a plain image, you cannot apply a HTML page within image tags.
Nobbie
 
Posts: 10345
Joined: 09. March 2008 13:04

Re: Tomcat won't start - everything else works (Windows 10)

Postby lisztv » 16. February 2018 21:17

Nobbie wrote:
lisztv wrote:Tomcat error message says that either Java is not installed or the port is not open as the cause of the error. However, I did install java and I assigned a new port number to tomcat.


No, it does NOT say that Java is not installed. It says that JDK and JRE are missing, only "Java" is an insufficient description. Did you install a JDK and a JRE, and did you check if the run properly? JDK = Java Development Kit, JRE = Java Runtime Environment

Try to run Tomcat NOT(!) as a service, try to run it directly from the Xampp Controlcenter not as service. Also start the Xampp Controlcenter as Administrator (right click Xampp icon and choose "Run as Administrator...").

Finally, your "images" arent images, your links points to HTML pages which also contains images, but that is quite a different thing than a plain image, you cannot apply a HTML page within image tags.


Nobbie, I installed the JDK after downloading it from the Oracle website. That is why when I entered 'java -version' from the cmd line that I got the output that I did (see the original image link above). Yes, I am aware of the difference between the JDK and the JRE. The former is a superset of the latter. Maybe I am misunderstanding this. Are you saying I should instead install the JDK *AND* also the JRE??

I tried to uncheck (the 'x' -- see the link below) but Xampp wouldn't let me remove the 'x'. (the link is a link to Microsoft's onedrive cloud facility):
https://1drv.ms/u/s!AiZXGlIfeoh8itopVu5KGJbwfPRrPA

Let me try displaying the link to the image above with the tags but this time not the html page:
Image

And try again (this is a copy and paste from Onedrive):
<img%20src="https://uvmryq-dm2305.files.1drv.com/y4mN-Ti2JmqPlVWaGbSn6oJV9px4SQdMUS4F9qKWHIOB-kP45e-G-iCLudNuxOQSOVris3wGkxvnfDt2f85Wtp8diOyd-Ev8TJlOJJF7p-6vx5rSwz5LKx8KNKw2Dk5tULzbi0l2KWQwyhA4RGos4TGJH8jd8uDEKDD2KtGIkHnz_Z7QWy9xOvwXVBosIYaYPxdB1icBCzyRFYp3iJYUwOyDw?width=1222&height=651&cropmode=none"%20width="1222"%20height="651"%20/>

Checking the preview function of this forum, the image still does not display. Why? Exactly how do I display an image in this forum. I read the FAQ before posting and it said that the image has to be in a 3rd party site. I Assume OneDrive or Dropbox would work. But it's not working. Btw, I'm using Chrome, Windows 10, and have 16 GB of RAM.
Thanks for trying to help Nobbie.
lisztv
 
Posts: 5
Joined: 16. February 2018 04:49
XAMPP version: 7.2.1
Operating System: Windows 10

Re: Tomcat won't start - everything else works (Windows 10)

Postby lisztv » 16. February 2018 21:52

Altrea wrote:
lisztv wrote:So how come these images are not showing?

Open your Browsers Web Developer Tools (commonly Key F12), go to the network tab (or something similar) and execute your "image" url and you will see, that there are many many requests fired for many many files. So that url does not contain true image stream data.


Thank you for trying to help, however, at this point in time I don't really need to understand the intricacies of why it is not working. All I want to do is display an image in this forum. That is, just make it work. Advice please? (I'm using Chrome and Windows 10).
lisztv
 
Posts: 5
Joined: 16. February 2018 04:49
XAMPP version: 7.2.1
Operating System: Windows 10

Re: Tomcat won't start - everything else works (Windows 10)

Postby lisztv » 17. February 2018 22:17

Got it working. The solution is here:

https://www.youtube.com/watch?v=JmmaeS7UZRk&feature=youtu.be

Part of the solution is to install an older version of Java (ie. v8) instead of the latest version from the Oracle website.
lisztv
 
Posts: 5
Joined: 16. February 2018 04:49
XAMPP version: 7.2.1
Operating System: Windows 10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests