No change after update

Problems with the Windows version of XAMPP, questions, comments, and anything related.

No change after update

Postby Katarn » 27. September 2004 13:39

Today I installed the 1.4.8 upgrade. A few days ago I already installed the 1.4.7 upgrade.

After the 1.4.7 upgrade, I started the service, and on the frontpage it said Version 1.4.7.

But now, after the installation of the 1.4.8 upgrade, it still says version 1.4.7. And when I click on phpinfo, it still says PHP 5.01.

But, when I go the the program files, and I look at the version of the php.exe and some *.dll files, it all says Version 5.02.2.

I have the feeling that something is not right here, but I don't know what.
Posts: 2
Joined: 27. September 2004 13:24
Location: Netherlands

Postby StTiLa » 28. September 2004 14:03

The version-number seems to be incorrect. I have the same problem. Take a look into htdocs\xampp\.version

In this file you're able to change the version number.

To use PHP5 you have to call php-switch.bat in your xampp-folder.

Real programmers don't document. If it was hard to write, it should be hard to understand.
Posts: 8
Joined: 28. September 2004 08:05

Postby Kristian Marcroft » 28. September 2004 14:52


as mentioned by my forman,

the .version files in htdocs and in the install dir were not updated.

To get the new PHP Versions to work, you have to execute the php-switch.bat twice.

Then all should work fine.

So long
User avatar
Kristian Marcroft
AF Moderator
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Katarn » 28. September 2004 15:06

Thank you both for your answer!

I'm now using the correct PHP version. :D
Posts: 2
Joined: 27. September 2004 13:24
Location: Netherlands

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests