xampp - apache starts but shutdowns unexpectedly

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xampp - apache starts but shutdowns unexpectedly

Postby twli » 12. February 2018 01:22

6:05:22 PM [main] Initializing Control Panel
6:05:22 PM [main] Windows Version: Pro 64-bit
6:05:22 PM [main] XAMPP Version: 7.2.1
6:05:22 PM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
6:05:22 PM [main] You are not running with administrator rights! This will work for
6:05:22 PM [main] most application stuff but whenever you do something with services
6:05:22 PM [main] there will be a security dialogue or things will break! So think
6:05:22 PM [main] about running this application with administrator rights!
6:05:22 PM [main] XAMPP Installation Directory: "c:\xampp\"
6:05:22 PM [main] Checking for prerequisites
6:05:22 PM [main] All prerequisites found
6:05:22 PM [main] Initializing Modules
6:05:22 PM [Apache] Initializing module...
6:05:22 PM [Apache] Checking for module existence...
6:05:22 PM [Apache] Checking for required tools...
6:05:22 PM [Apache] Checking for service (name="Apache2.4"): Service not installed
6:05:22 PM [Apache] Service Path: Service Not Installed
6:05:22 PM [Apache] Checking default ports...
6:05:22 PM [mysql] Initializing module...
6:05:22 PM [mysql] Checking for module existence...
6:05:22 PM [mysql] Checking for required tools...
6:05:22 PM [mysql] Checking for service (name="mysql"): Service not installed
6:05:22 PM [mysql] Service Path: Service Not Installed
6:05:22 PM [mysql] Checking default ports...
6:05:22 PM [mysql] Portblocker Detected: mysqld.exe
6:05:22 PM [mysql] Checking for App: c:\xampp\mysql\bin\mysqld.exe
6:05:22 PM [mysql] Portblocker Path: C:\xampp\mysql\bin\mysqld.exe
6:05:22 PM [mysql] Portblocker Service Path:
6:05:22 PM [mysql] XAMPP MySQL is already running on port 3306
6:05:22 PM [filezilla] Initializing module...
6:05:22 PM [filezilla] Checking for module existence...
6:05:22 PM [filezilla] Checking for required tools...
6:05:22 PM [filezilla] Checking for service (name="FileZillaServer"): Service not installed
6:05:22 PM [filezilla] Service Path: Service Not Installed
6:05:22 PM [filezilla] Checking default ports...
6:05:22 PM [filezilla] Portblocker Detected: filezillaserver.exe
6:05:22 PM [filezilla] Checking for App: c:\xampp\FileZillaFTP\filezillaserver.exe
6:05:22 PM [filezilla] Portblocker Path: C:\xampp\FileZillaFTP\FileZillaServer.exe
6:05:22 PM [filezilla] Portblocker Service Path:
6:05:22 PM [filezilla] XAMPP FileZilla is already running on port 21
6:05:22 PM [filezilla] Portblocker Detected: filezillaserver.exe
6:05:22 PM [filezilla] Checking for App: c:\xampp\FileZillaFTP\filezillaserver.exe
6:05:22 PM [filezilla] Portblocker Path: C:\xampp\FileZillaFTP\FileZillaServer.exe
6:05:22 PM [filezilla] Portblocker Service Path:
6:05:22 PM [filezilla] XAMPP FileZilla is already running on port 14147
6:05:22 PM [main] The Mercury module is disabled
6:05:22 PM [main] The Tomcat module is disabled
6:05:22 PM [main] Enabling autostart for module "Apache"
6:05:22 PM [main] Enabling autostart for module "MySQL"
6:05:22 PM [main] Starting Check-Timer
6:05:22 PM [main] Control Panel Ready
6:05:23 PM [Apache] Autostart active: starting...
6:05:23 PM [Apache] Checking default ports...
6:05:23 PM [Apache] Attempting to start Apache app...
6:05:23 PM [Apache] Executing "c:\xampp\apache\bin\httpd.exe"
6:05:23 PM [Apache] Return code: 0
6:05:23 PM [mysql] Autostart aborted: MySQL is already running
6:05:23 PM [Apache] Status change detected: running
6:05:26 PM [Apache] Status change detected: stopped
6:05:26 PM [Apache] Error: Apache shutdown unexpectedly.
6:05:26 PM [Apache] This may be due to a blocked port, missing dependencies,
6:05:26 PM [Apache] improper privileges, a crash, or a shutdown by another method.
6:05:26 PM [Apache] Press the Logs button to view error logs and check
6:05:26 PM [Apache] the Windows Event Viewer for more clues
6:05:26 PM [Apache] If you need more help, copy and post this
6:05:26 PM [Apache] entire log window on the forums
6:19:56 PM [Apache] Checking default ports...
6:19:56 PM [Apache] Attempting to start Apache app...
6:19:56 PM [Apache] Executing "c:\xampp\apache\bin\httpd.exe"
6:19:56 PM [Apache] Return code: 0
6:19:57 PM [Apache] Status change detected: running
6:20:00 PM [Apache] Status change detected: stopped
6:20:00 PM [Apache] Error: Apache shutdown unexpectedly.
6:20:00 PM [Apache] This may be due to a blocked port, missing dependencies,
6:20:00 PM [Apache] improper privileges, a crash, or a shutdown by another method.
6:20:00 PM [Apache] Press the Logs button to view error logs and check
6:20:00 PM [Apache] the Windows Event Viewer for more clues
6:20:00 PM [Apache] If you need more help, copy and post this
6:20:00 PM [Apache] entire log window on the forums
twli
 
Posts: 1
Joined: 12. February 2018 01:06
XAMPP version: 7.2.1
Operating System: Windows 10

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests