Services can't start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Services can't start

Postby Marius S » 31. January 2018 05:23

I am new to Xampp, and tried to install it today.
The first time it installed, I then tried to connect but nothing wanted to start up (except the control panel, which I "run as administrator".
I tried to install "Bitnami for Xampp", it did not work. Thinking I made a mistake, I uninstalled, restarted my laptop and tried to reinstall. I got a message to say the Progamfiles(86)/Xampp folder was not empty. (Even though I cannot find it anywhere.)
I created anew folder in Programfiles/xampp and used that as a destination, after I noticed there could be a problem with the programs(86) directory.
I can still bring up the Xamp control panel, managed to start Apache, but cannot install Bitnami, because MySQL would'not start up. This is the message I get:
5:04:49 PM [main] Initializing Control Panel
5:04:49 PM [main] Windows Version: Home 64-bit
5:04:49 PM [main] XAMPP Version: 7.2.1
5:04:49 PM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
5:04:49 PM [main] Running with Administrator rights - good!
5:04:49 PM [main] XAMPP Installation Directory: "c:\program files\xampp\"
5:04:49 PM [main] WARNING: Your install directory contains spaces. This may break programs/scripts
5:04:49 PM [main] Checking for prerequisites
5:04:49 PM [main] All prerequisites found
5:04:49 PM [main] Initializing Modules
5:04:49 PM [main] Enabling autostart for module "Apache"
5:04:49 PM [main] Enabling autostart for module "MySQL"
5:04:49 PM [main] Starting Check-Timer
5:04:49 PM [main] Control Panel Ready
5:04:49 PM [Apache] Autostart active: starting...
5:04:49 PM [Apache] Attempting to start Apache app...
5:04:49 PM [mysql] Autostart active: starting...
5:04:49 PM [mysql] Attempting to start MySQL app...
5:04:51 PM [mysql] Status change detected: running
5:04:51 PM [mysql] Status change detected: stopped
5:04:51 PM [mysql] Error: MySQL shutdown unexpectedly.
5:04:51 PM [mysql] This may be due to a blocked port, missing dependencies,
5:04:51 PM [mysql] improper privileges, a crash, or a shutdown by another method.
5:04:51 PM [mysql] Press the Logs button to view error logs and check
5:04:51 PM [mysql] the Windows Event Viewer for more clues
5:04:51 PM [mysql] If you need more help, copy and post this
5:04:51 PM [mysql] entire log window on the forums

Can anybody help?
Marius S
 
Posts: 3
Joined: 31. January 2018 05:10
XAMPP version: 7.2.1-0-VC
Operating System: Windows 10

Re: Services can't start

Postby Franklin46 » 31. January 2018 11:56

I am also new and I encountered the same problem today. If you check the log files it will probably tell you that port 3306 is in use by another session of phpMy admin. I solved the problem by changing the default port to 3307.
Do not change the port in Xampp control panel, it won't work. You have to change it in the configuration file. Close the Xamp control panel then go to XAMPP/mysql/bin/ directory where you installed XAMPP. Open the "my.ini" file in Notepad and change the 3306 to 3307 (or something else) in 3 instances; save the file then re-open control panel and phpMy admin should start.
Hope it works for you.
Franklin46
 
Posts: 2
Joined: 31. January 2018 11:10
XAMPP version: 3.2.2
Operating System: Windows 10 home

Re: Services can't start

Postby Marius S » 31. January 2018 22:32

Thanks for the advice.
I tried that, but Windows would not let me save the changes. I get the message that I do not authority to change it. I need to contact the owner of the file or administrator. It is one of those Windows things that drives me insane. It is my computer, nobody else uses the thing. So any ideas how I open it with administrator privileges?
Marius S
 
Posts: 3
Joined: 31. January 2018 05:10
XAMPP version: 7.2.1-0-VC
Operating System: Windows 10

Re: Services can't start

Postby Marius S » 01. February 2018 00:33

I apologise for the double posting, I realise it is against the rules. I just need to give some feedback and ask another question.
I have managed to change the ports in my.ini to 3307, now I have a problem with installing the Bitnami modules.
I get the message that it cannot connect to the mysql server. I checked the XAMPP control panel and it is running.
Any ideas.
Marius S
 
Posts: 3
Joined: 31. January 2018 05:10
XAMPP version: 7.2.1-0-VC
Operating System: Windows 10

Re: Services can't start

Postby Franklin46 » 01. February 2018 00:59

I didnt go down the Bitnami modules path so I cant help with that except to suggest Bitnami is more than likely looking for the default port 3306?
Another approach would be to close the application that is using port 3306 then change XAMPP back to that default port setting. I cant give you a tut on exactly how to go about it because it depends greatly on the version of Windows you are running and how your machine is set up. It is not really very hard or complicated but you will have to google a bit of advice to get you going.
Franklin46
 
Posts: 2
Joined: 31. January 2018 11:10
XAMPP version: 3.2.2
Operating System: Windows 10 home


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 35 guests