XAMPP compatibility with Windows 2008 R2 (64)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP compatibility with Windows 2008 R2 (64)

Postby chingupt » 30. January 2018 16:47

Dear All,

I have been spending many days and nights trying to setup XAMPP (7.2) on a Windows 2008 R2 instance.
I have Java Version 7 installed and am trying to install via Admin rights in a custom directory.

Post the installation, the services fail to come up except for Tomcat.

Can you please guide if there are compatibility issues reported with this OS version?

I need to have the latest version of XAMPP installed with latest Apache/Tomcat to rule out any vulnerabilities.

Please suggest.

Best Regards
chingupt
 
Posts: 3
Joined: 30. January 2018 16:42
XAMPP version: 7,2
Operating System: WINDOWS 2008 R2 (64)

Re: XAMPP compatibility with Windows 2008 R2 (64)

Postby Altrea » 30. January 2018 16:58

Hi,

If you are aware of vulnerabilities XAMPP is the wrong product for you.
Better install the single components all on its own and configure them.
Advantages are that you have full control about the configuration and can update any of the components on its own. (which is not possible with XAMPP).

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9257
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: XAMPP compatibility with Windows 2008 R2 (64)

Postby chingupt » 30. January 2018 17:03

Thanks Altrea,

I need to try at least. But cant seem to get the XAMPP 7.2 working on Windows 2008 R2 (64).
Are there known compatibility issues on this OS for the latest version?

Regards
chingupt
 
Posts: 3
Joined: 30. January 2018 16:42
XAMPP version: 7,2
Operating System: WINDOWS 2008 R2 (64)

Re: XAMPP compatibility with Windows 2008 R2 (64)

Postby Altrea » 30. January 2018 17:23

That is not a question of trying. Once a month i have to answer the same question. XAMPP is local test and development environment. It is not hardened and will not focus on security. The XAMPP developers are not responsible to fix any known or unknown security issues.
XAMPP gets released nearly once a month. So if a security issue is released a day after a XAMPP release it can take more than a month to the next XAMPP release maybe fixing this version. XAMPP is not updateable, so every XAMPP version change is always a fresh installation/migration (backup and restore) of all webapplications and settings.
So, if you are aware of any security issues, security assessments or anything similar, don't use XAMPP.

And no, i don't have any information about incompatibilities or bugs relating XAMPP 7.2.1 and Windows Server 2008 R2.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9257
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 38 guests