Page 1 of 1

MySql not working

PostPosted: 29. January 2018 02:51
by Jamora1124
I'm not sure what's going on. I tried installing and then uninstalling this program a bunch of times. I clicked to "Allow access" for the Apache server, however, I am having a hard time trying to start a MySql connection. It said something about access denied because a certain file was not created when the program was downloaded. I am following a Youtube tutorial on how to start an MMORPG server.

Here is the error message I am receiving.

8:46:22 PM [main] Initializing Control Panel
8:46:22 PM [main] Windows Version: Home 64-bit
8:46:22 PM [main] XAMPP Version: 7.1.13
8:46:22 PM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
8:46:22 PM [main] You are not running with administrator rights! This will work for
8:46:22 PM [main] most application stuff but whenever you do something with services
8:46:22 PM [main] there will be a security dialogue or things will break! So think
8:46:22 PM [main] about running this application with administrator rights!
8:46:22 PM [main] XAMPP Installation Directory: "c:\xampp\"
8:46:22 PM [main] Checking for prerequisites
8:46:22 PM [main] All prerequisites found
8:46:22 PM [main] Initializing Modules
8:46:22 PM [main] The FileZilla module is disabled
8:46:22 PM [main] The Mercury module is disabled
8:46:22 PM [main] The Tomcat module is disabled
8:46:22 PM [main] Starting Check-Timer
8:46:22 PM [main] Control Panel Ready
8:46:28 PM [mysql] Attempting to start MySQL app...
8:46:30 PM [mysql] Status change detected: running
8:46:30 PM [mysql] Status change detected: stopped
8:46:30 PM [mysql] Error: MySQL shutdown unexpectedly.
8:46:30 PM [mysql] This may be due to a blocked port, missing dependencies,
8:46:30 PM [mysql] improper privileges, a crash, or a shutdown by another method.
8:46:30 PM [mysql] Press the Logs button to view error logs and check
8:46:30 PM [mysql] the Windows Event Viewer for more clues
8:46:30 PM [mysql] If you need more help, copy and post this
8:46:30 PM [mysql] entire log window on the forums

It says I'm not running with administrator rights however, I'm the only user of this computer. I would assume that this account would be the administrator but I guess not. Could anyone help?

Re: MySql not working

PostPosted: 29. January 2018 10:42
by Jamora1124
Sorry for the double post. I know how Forum Rules work. I figured out the problem a few hours ago. If I run the program from the Start Menu as an administrator, it works perfectly fine.