Page 1 of 1

Something is wrong with the xxamp installation?

PostPosted: 12. January 2018 20:58
by TheMidnightWar
I got this when i opened my index.php in htdocs
Something is wrong with the XAMPP installation :-(

is it suppose to look like this
<?php
if (!empty($_SERVER['HTTPS']) && ('on' == $_SERVER['HTTPS'])) {
$uri = 'https://';
} else {
$uri = 'http://';
}
$uri .= $_SERVER['HTTP_HOST'];
header('Location: '.$uri.'/dashboard/');
exit;
?>
Something is wrong with the XAMPP installation :-(

Re: Something is wrong with the xxamp installation?

PostPosted: 12. January 2018 22:02
by Altrea
Yes

Re: Something is wrong with the xxamp installation?

PostPosted: 12. January 2018 22:12
by Nobbie
TheMidnightWar wrote:I got this when i opened my index.php in htdocs


And how did you do this? Am i right, you simply double clicked index.php in your explorer? If "yes", it is totally wrong. Instead enter "http://localhost" into your browser and see, what happens.

Re: Something is wrong with the xxamp installation?

PostPosted: 12. January 2018 23:01
by TheMidnightWar
I opened the file with notepad++.

Re: Something is wrong with the xxamp installation?

PostPosted: 12. January 2018 23:02
by TheMidnightWar
Nobbie wrote:
TheMidnightWar wrote:I got this when i opened my index.php in htdocs


And how did you do this? Am i right, you simply double clicked index.php in your explorer? If "yes", it is totally wrong. Instead enter "http://localhost" into your browser and see, what happens.


http://localhost/dashboard/
Brings me to welcome XXAMP.

Re: Something is wrong with the xxamp installation?

PostPosted: 13. January 2018 00:34
by Nobbie
Perfectly fine.

Re: Something is wrong with the xxamp installation?

PostPosted: 18. February 2019 18:08
by TheMidnightWar
Altrea wrote:Yes

When I watch a video on this there's don't say that message

Re: Something is wrong with the xxamp installation?

PostPosted: 18. February 2019 19:05
by Altrea
Because the video is years old?

Re: Something is wrong with the xxamp installation?

PostPosted: 18. February 2019 19:09
by TheMidnightWar
Can you give me a updated tutorial? All I need to know is after I set localhost to localhost:8852 how do I add a custom domain. I want it to be public for only my discord to access

Re: Something is wrong with the xxamp installation?

PostPosted: 18. February 2019 19:31
by Altrea
We don't provide such help because XAMPP is not made for public accessible environments.
Read more about that in the forum rules viewtopic.php?f=16&t=67782#p232732 {section: scope of support)