Allow remote access to wordpress

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Allow remote access to wordpress

Postby topdoozer » 10. January 2018 15:16

Hi! What changes do i need to apply to a new installation of XAMPP (7.1.11) and the wordpress Bitnami package on a Windows 7 Ultimate machine so i can let a customer view the wordpress blog i am creating for them? I have a NOIP account that i am using to route traffic to my computer and the port checking tool from NOIP tells me that it can reach port 80 on my computer (so port forwarding seems to be working and no problem with firewall or Antivirus). Yet any request made to my computer from the outside times out without any other error message.

This is what my httpd-xampp.conf looks like:

</IfModule>

#
# PHP-Module setup
#
LoadFile "D:/xampp/php/php7ts.dll"
LoadFile "D:/xampp/php/libpq.dll"
LoadModule php7_module "D:/xampp/php/php7apache2_4.dll"

<FilesMatch "\.php$">
SetHandler application/x-httpd-php
</FilesMatch>
<FilesMatch "\.phps$">
SetHandler application/x-httpd-php-source
</FilesMatch>

#
# PHP-CGI setup
#
#<FilesMatch "\.php$">
# SetHandler application/x-httpd-php-cgi
#</FilesMatch>
#<IfModule actions_module>
# Action application/x-httpd-php-cgi "/php-cgi/php-cgi.exe"
#</IfModule>


<IfModule php7_module>
PHPINIDir "D:/xampp/php"
</IfModule>

<IfModule mime_module>
AddType text/html .php .phps
</IfModule>

ScriptAlias /php-cgi/ "D:/xampp/php/"
<Directory "D:/xampp/php">
AllowOverride None
Options None
Require all denied
<Files "php-cgi.exe">
Require all granted
</Files>
</Directory>

<Directory "D:/xampp/cgi-bin">
<FilesMatch "\.php$">
SetHandler cgi-script
</FilesMatch>
<FilesMatch "\.phps$">
SetHandler None
</FilesMatch>
</Directory>

<Directory "D:/xampp/htdocs/xampp">
<IfModule php7_module>
<Files "status.php">
php_admin_flag safe_mode off
</Files>
</IfModule>
AllowOverride AuthConfig
</Directory>

<IfModule alias_module>
Alias /licenses "D:/xampp/licenses/"
<Directory "D:/xampp/licenses">
Options +Indexes
<IfModule autoindex_color_module>
DirectoryIndexTextColor "#000000"
DirectoryIndexBGColor "#f8e8a0"
DirectoryIndexLinkColor "#bb3902"
DirectoryIndexVLinkColor "#bb3902"
DirectoryIndexALinkColor "#bb3902"
</IfModule>
Require local
ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</Directory>

Alias /phpmyadmin "D:/xampp/phpMyAdmin/"
<Directory "D:/xampp/phpMyAdmin">
AllowOverride AuthConfig
Require local
ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</Directory>

Alias /webalizer "D:/xampp/webalizer/"
<Directory "D:/xampp/webalizer">
<IfModule php7_module>
<Files "webalizer.php">
php_admin_flag safe_mode off
</Files>
</IfModule>
AllowOverride AuthConfig
Require local
ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</Directory>
</IfModule>
topdoozer
 
Posts: 1
Joined: 10. January 2018 15:10
XAMPP version: 7.1.11
Operating System: Windos 7 Ultimate

Re: Allow remote access to wordpress

Postby Nobbie » 10. January 2018 16:00

topdoozer wrote:Hi! What changes do i need to apply to a new installation of XAMPP (7.1.11) and the wordpress Bitnami package on a Windows 7 Ultimate machine so i can let a customer view the wordpress blog i am creating for them?


None. You have a problem with a firewall or somewhat else. Nothing need to be changed for Xampp. Please keep in mind that Xampp is not meant for public access, it is designed for development only.
Nobbie
 
Posts: 9886
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests