Allow remote access to wordpress

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Allow remote access to wordpress

Postby topdoozer » 10. January 2018 15:16

Hi! What changes do i need to apply to a new installation of XAMPP (7.1.11) and the wordpress Bitnami package on a Windows 7 Ultimate machine so i can let a customer view the wordpress blog i am creating for them? I have a NOIP account that i am using to route traffic to my computer and the port checking tool from NOIP tells me that it can reach port 80 on my computer (so port forwarding seems to be working and no problem with firewall or Antivirus). Yet any request made to my computer from the outside times out without any other error message.

This is what my httpd-xampp.conf looks like:

</IfModule>

#
# PHP-Module setup
#
LoadFile "D:/xampp/php/php7ts.dll"
LoadFile "D:/xampp/php/libpq.dll"
LoadModule php7_module "D:/xampp/php/php7apache2_4.dll"

<FilesMatch "\.php$">
SetHandler application/x-httpd-php
</FilesMatch>
<FilesMatch "\.phps$">
SetHandler application/x-httpd-php-source
</FilesMatch>

#
# PHP-CGI setup
#
#<FilesMatch "\.php$">
# SetHandler application/x-httpd-php-cgi
#</FilesMatch>
#<IfModule actions_module>
# Action application/x-httpd-php-cgi "/php-cgi/php-cgi.exe"
#</IfModule>


<IfModule php7_module>
PHPINIDir "D:/xampp/php"
</IfModule>

<IfModule mime_module>
AddType text/html .php .phps
</IfModule>

ScriptAlias /php-cgi/ "D:/xampp/php/"
<Directory "D:/xampp/php">
AllowOverride None
Options None
Require all denied
<Files "php-cgi.exe">
Require all granted
</Files>
</Directory>

<Directory "D:/xampp/cgi-bin">
<FilesMatch "\.php$">
SetHandler cgi-script
</FilesMatch>
<FilesMatch "\.phps$">
SetHandler None
</FilesMatch>
</Directory>

<Directory "D:/xampp/htdocs/xampp">
<IfModule php7_module>
<Files "status.php">
php_admin_flag safe_mode off
</Files>
</IfModule>
AllowOverride AuthConfig
</Directory>

<IfModule alias_module>
Alias /licenses "D:/xampp/licenses/"
<Directory "D:/xampp/licenses">
Options +Indexes
<IfModule autoindex_color_module>
DirectoryIndexTextColor "#000000"
DirectoryIndexBGColor "#f8e8a0"
DirectoryIndexLinkColor "#bb3902"
DirectoryIndexVLinkColor "#bb3902"
DirectoryIndexALinkColor "#bb3902"
</IfModule>
Require local
ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</Directory>

Alias /phpmyadmin "D:/xampp/phpMyAdmin/"
<Directory "D:/xampp/phpMyAdmin">
AllowOverride AuthConfig
Require local
ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</Directory>

Alias /webalizer "D:/xampp/webalizer/"
<Directory "D:/xampp/webalizer">
<IfModule php7_module>
<Files "webalizer.php">
php_admin_flag safe_mode off
</Files>
</IfModule>
AllowOverride AuthConfig
Require local
ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</Directory>
</IfModule>
topdoozer
 
Posts: 3
Joined: 10. January 2018 15:10
XAMPP version: 7.1.11
Operating System: Windos 7 Ultimate

Re: Allow remote access to wordpress

Postby Nobbie » 10. January 2018 16:00

topdoozer wrote:Hi! What changes do i need to apply to a new installation of XAMPP (7.1.11) and the wordpress Bitnami package on a Windows 7 Ultimate machine so i can let a customer view the wordpress blog i am creating for them?


None. You have a problem with a firewall or somewhat else. Nothing need to be changed for Xampp. Please keep in mind that Xampp is not meant for public access, it is designed for development only.
Nobbie
 
Posts: 10601
Joined: 09. March 2008 13:04

Re: Allow remote access to wordpress

Postby topdoozer » 23. January 2018 17:12

How do i determine where the problem is? I shut down firewall and Antivirus tool, used a port check tool to make sure that my router is forwarding correctly (the tool says it can see the port as open) and yet i cannot access my local apache webserver from the internet. I do not even see any line in the apache access log being added, so i am guessing the request does not get to my webserver.
topdoozer
 
Posts: 3
Joined: 10. January 2018 15:10
XAMPP version: 7.1.11
Operating System: Windos 7 Ultimate

Re: Allow remote access to wordpress

Postby Nobbie » 23. January 2018 20:00

How do you test your installation? Try to access from a different PC (not from the Xampp PC), either from a different PC within the same LAN, but also with a PC (or a smartphone/tablet) from outside. Some routers have problem to access any PC within the same LAN via external IP, they lack so called "NAT loopback".

See http://opensimulator.org/wiki/NAT_Loopback_Routers for more information about NAT loopback and check if your router can or cannot. Any AVM Fritzbox can do NAT Loopback, but there are many routers out there which cannot. I dont know if that is your problem, but it might be. If you tell me your NOIP domain, i also could check from my home.
Nobbie
 
Posts: 10601
Joined: 09. March 2008 13:04

Re: Allow remote access to wordpress

Postby topdoozer » 23. January 2018 20:35

Aha! Well, maybe that explains it. I am behind a Zyxel C1100Z router and i see in the table on opensimulator the Zyxel C1000 as not capable of NAT looback or Hairpinning. I am using my Xamp Pc to access my web server through the public IP address of the router. So if the router does not do hairpinning, if i understand it correctly, it would drop the request? Could i circumvent that by using NOIP, or do i have to use a different device? ................. sorry, i just tested it with another device and yes, my Zyxel C1100Z router cannot do hairpinnig. Very frustrating indeed! Thanks very much for the awesome help Nobbie! (was able to access the web server from different device!)
topdoozer
 
Posts: 3
Joined: 10. January 2018 15:10
XAMPP version: 7.1.11
Operating System: Windos 7 Ultimate


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 65 guests