Chrome has problem with using virtual hosts?!?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Chrome has problem with using virtual hosts?!?

Postby artoo_s » 07. January 2018 09:21

I have a few virtual hosts setup to use with the latest XAMPP and they work great with Firefox but when I try to use Chrome with these virtual host addresses, I'm getting "Your connection is not private" error.

Chrome does allow me to use the addresses "localhost" and "localhost/phpmyAdmin" without any problems.

Has anyone figured out how to set up the latest version of Chrome to work with XAMPP's virtual host addresses such as movieDB.dev that I have set up in the httpd-vhosts.conf configuration file.
artoo_s
 
Posts: 10
Joined: 10. December 2014 04:16
Operating System: Windows 7 Ultimate

Re: Chrome has problem with using virtual hosts?!?

Postby Altrea » 07. January 2018 12:37

Never had problems with virtual hosts in Chrome.
Did you try to google for “Your connection is not private“?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Re: Chrome has problem with using virtual hosts?!?

Postby artoo_s » 07. January 2018 19:16

Followed what was shown in the videos and still getting the error. Also noticed that I'm getting an error of NET::ERR_CERT_AUTHORITY_INVALID
artoo_s
 
Posts: 10
Joined: 10. December 2014 04:16
Operating System: Windows 7 Ultimate

Re: Chrome has problem with using virtual hosts?!?

Postby Nobbie » 07. January 2018 20:08

It is Chrome issue anyway and this is NOT a Chrome support forum. It has nothing to do with Xampp or VirtualHosts, thats only a side effect. Good luck, but we cannot solve Chrome problems.
Nobbie
 
Posts: 10509
Joined: 09. March 2008 13:04

Re: Chrome has problem with using virtual hosts?!?

Postby binalepuffs » 05. June 2018 05:57

Reason of " connection is not private " error

Wrong date and time
Antivirus block SSL Connection
Invalid Google chrome Cache and Cookies files
Expired SSL certificate
Firewall Error
Browser Error

HOW TO FIX SSL CONNECTION ERROR?

Check your date and time
Exclude SSL protocol scanning in your antivirus settings
Google chrome and Mozilla Firefox browser tweaks
Export and import website’s SSL certificate
System restore your windows in previous date before the SSL connection error occur

http://net-informations.com/q/mis/ssl.html
binalepuffs
 
Posts: 1
Joined: 05. June 2018 05:55
XAMPP version: 3.2.2
Operating System: win 8

Re: Chrome has problem with using virtual hosts?!?

Postby InsiteFX » 25. June 2018 12:11

You need to setup an SSL Certificate and install it then create vhosts to use it

#--------------------------------------------------------------
# HTTP:
#--------------------------------------------------------------
<VirtualHost *:80>
DocumentRoot "C:/xampp/htdocs/ci4modules/public_html"
ServerName ci4modules.local
ServerAlias ci4modules.local
<Directory "C:/xampp/htdocs/ci4modules/public_html">
Order allow,deny
Allow from all
AllowOverride All
Require all granted
</Directory>
</VirtualHost>

#--------------------------------------------------------------
# HTTPS:
#--------------------------------------------------------------
<VirtualHost *:443>
DocumentRoot "C:/xampp/htdocs/ci4modules/public_html"
ServerName ci4modules.local
ServerAlias ci4modules.local
SSLEngine on
SSLCertificateFile "conf/ssl.crt/server.crt"
SSLCertificateKeyFile "conf/ssl.key/server.key"
<Directory "C:/xampp/htdocs/ci4modules/public_html">
Options All
AllowOverride All
Require all granted
</Directory>
</VirtualHost>

Change everything for you setup

Chrome will still error but click advance and tell it to use anyways.
InsiteFX
 
Posts: 6
Joined: 03. April 2011 17:19


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 34 guests

cron