Installer for 7.1.12 fails on Windows

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Installer for 7.1.12 fails on Windows

Postby vgriffin » 20. December 2017 05:09

When I tried to use the installer for 7.1.12, it ran for a while (probably decompressing....) and kind of displayed a window (behind all other windows, so I missed it the first couple of times) with the following text: Windows cannot find '-n'. Make sure you typed the name correctly, and then try again.

I already had 7.1.8 installed on my dev machine. I wanted to see if another issue (I'll report it in another topic) was fixed and wanted to create instructions for installation on my test machine, so I already had php and other components.

Possibly-unusual features on my system are MariaDB 10.3.2 (Alpha) and Java 9.0.1.

I tried downloading the zip version, and it seems to have installed. (I've got to change all of the ports before it will run.)

I KNOW it's on the latest version of Windows because I rebooted it when it seemed to be hung. (The error window was hiding behind the status window, waiting for me to press the Okay button.) And there was a Windows upgrade waiting for me....
vgriffin
 
Posts: 8
Joined: 20. December 2017 04:53
XAMPP version: 7.1.12
Operating System: Windows 10

Re: Installer for 7.1.12 fails on Windows

Postby vgriffin » 22. December 2017 05:58

It fails on 7.2.0 the same way.
vgriffin
 
Posts: 8
Joined: 20. December 2017 04:53
XAMPP version: 7.1.12
Operating System: Windows 10

Re: Installer for 7.1.12 fails on Windows

Postby Nobbie » 22. December 2017 11:19

I googled for the error message and got a hint, this might happen if you apply a folder with a space as installation folder (for example "c:/My Xampp" or similar).
Nobbie
 
Posts: 10237
Joined: 09. March 2008 13:04

Re: Installer for 7.1.12 fails on Windows

Postby vgriffin » 24. December 2017 03:24

No, that's not the problem. I don't use spaces in my directory names to protect myself against sloppy scripts. I followed the same steps I had when I installed 7.1.8 in the same directory. (As part of my process, I change the new directory to include the version in its name.) If I manually unzip it and run setup_xampp.bat from the new directory, it works. Also, error messages should not be displayed UNDER the window for the process generating the error!
vgriffin
 
Posts: 8
Joined: 20. December 2017 04:53
XAMPP version: 7.1.12
Operating System: Windows 10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 27 guests