Apache has stopped working before I've finished installation

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache has stopped working before I've finished installation

Postby Supercon22 » 07. November 2017 00:14

So I need to use Apache for something but for some reason, the installation simply doesn't work. It starts to install and then says "Apache HTTP server has stopped working." XAMPP installs fine and MySQL works but when I try to start Apache, I get the same error. I've looked online for an hour and I've tried many solutions but none of them work for me and I have no clue what the problem is as I've followed the instructions spot on. Can someone please help me?
Supercon22
 
Posts: 17
Joined: 07. November 2017 00:11
XAMPP version: Uninstalled
Operating System: Windows

Re: Apache has stopped working before I've finished installa

Postby Supercon22 » 07. November 2017 16:54

I've found some more info.

I start apache and I can tell that port 80 and 443 are open but Apache instantly crashes with the windows error: "Apache HTTP Server has stopped working".

15:54:06 [Apache] Attempting to start Apache app...
15:54:07 [Apache] Status change detected: running
15:54:24 [Apache] Status change detected: stopped
15:54:24 [Apache] Error: Apache shutdown unexpectedly.
15:54:24 [Apache] This may be due to a blocked port, missing dependencies,
15:54:24 [Apache] improper privileges, a crash, or a shutdown by another method.
15:54:24 [Apache] Press the Logs button to view error logs and check
15:54:24 [Apache] the Windows Event Viewer for more clues
15:54:24 [Apache] If you need more help, copy and post this
15:54:24 [Apache] entire log window on the forums

I check the logs and the only error is this: [Tue Nov 07 15:54:07.580994 2017] [ssl:warn] [pid 7364:tid 256] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
Supercon22
 
Posts: 17
Joined: 07. November 2017 00:11
XAMPP version: Uninstalled
Operating System: Windows

Re: Apache has stopped working before I've finished installa

Postby Supercon22 » 07. November 2017 17:52

I am 100% sure the ports are not blocked so either the installation went wrong (I've installed it several times now) or something else is closing it.

I've also found out my firewalls aren't obstructing it so it's got to be something to do with the code being broken. The XAMPP version says it is v3.2.2
Supercon22
 
Posts: 17
Joined: 07. November 2017 00:11
XAMPP version: Uninstalled
Operating System: Windows

Re: Apache has stopped working before I've finished installa

Postby Nobbie » 07. November 2017 19:14

Open a terminal (cmd.exe), proceed to c:/xampp/apache/bin (cd /xampp/apache/bin) and enter "httpd" and hit return. This starts Apache (= httpd.exe) manually out of a terminal, and you probably will see an error message during startup. Tell us, what is happening and we will find out, what is going wrong.
Nobbie
 
Posts: 9761
Joined: 09. March 2008 13:04

Re: Apache has stopped working before I've finished installa

Postby Supercon22 » 07. November 2017 21:33

I opened a terminal and opend httpd.exe but it didn't give any error message except the "Apache HTTP Server has stopped working" in google - nothing in cmd.exe.
Supercon22
 
Posts: 17
Joined: 07. November 2017 00:11
XAMPP version: Uninstalled
Operating System: Windows

Re: Apache has stopped working before I've finished installa

Postby Supercon22 » 08. November 2017 10:04

Faulting application name: httpd.exe, version: 2.4.28.0, time stamp: 0x59d4a9ab
Faulting module name: mod_version.so, version: 2.4.28.0, time stamp: 0x59d4a9b0
Exception code: 0xc0000005
Fault offset: 0x00000870
Faulting process id: 0x15a0
Faulting application start time: 0x01d3586ed92e5787
Faulting application path: c:\xampp\apache\bin\httpd.exe
Faulting module path: C:\xampp\apache\modules\mod_version.so
Report Id: 18c711d5-c462-11e7-84f0-cb55049d9b8a

This is the error I found using event viewer (windows).
Supercon22
 
Posts: 17
Joined: 07. November 2017 00:11
XAMPP version: Uninstalled
Operating System: Windows

Re: Apache has stopped working before I've finished installa

Postby Nobbie » 08. November 2017 11:07

Sorry, that error is out of the scope of this forum. We only can help on basic technical issues, but this one looks like a severe bug (runtime error) in the executable. Can you try another installer (there are different Xampp versions on Sourceforge) and/or another PC? By the way, which WIndows are you running?
Nobbie
 
Posts: 9761
Joined: 09. March 2008 13:04

Re: Apache has stopped working before I've finished installa

Postby Supercon22 » 08. November 2017 11:44

I'm using Windows 7 Home Premium and I'll try different versions now as it's my last hope!
Supercon22
 
Posts: 17
Joined: 07. November 2017 00:11
XAMPP version: Uninstalled
Operating System: Windows

Re: Apache has stopped working before I've finished installa

Postby Supercon22 » 08. November 2017 11:54

And it doesn't work...
Supercon22
 
Posts: 17
Joined: 07. November 2017 00:11
XAMPP version: Uninstalled
Operating System: Windows

Re: Apache has stopped working before I've finished installa

Postby Nobbie » 08. November 2017 13:13

There must be someting wrong with your Windows, maybe a damaged DLL or a virus or invalid downloads or whatever. This error is unknown (not only to me) and usually Xampp installs without any flaws.
Nobbie
 
Posts: 9761
Joined: 09. March 2008 13:04

Re: Apache has stopped working before I've finished installa

Postby Supercon22 » 08. November 2017 13:34

There's nothing wrong with my windows.
Supercon22
 
Posts: 17
Joined: 07. November 2017 00:11
XAMPP version: Uninstalled
Operating System: Windows

Re: Apache has stopped working before I've finished installa

Postby Nobbie » 08. November 2017 13:36

There is nothing wrong with Xampp as well.
Nobbie
 
Posts: 9761
Joined: 09. March 2008 13:04

Re: Apache has stopped working before I've finished installa

Postby Supercon22 » 08. November 2017 13:55

It's clearly not working the way it should though.
Supercon22
 
Posts: 17
Joined: 07. November 2017 00:11
XAMPP version: Uninstalled
Operating System: Windows

Re: Apache has stopped working before I've finished installa

Postby Supercon22 » 08. November 2017 14:09

Apache doesn't work. I'm not one of your programmers so I don't know how to fix it for you.
Supercon22
 
Posts: 17
Joined: 07. November 2017 00:11
XAMPP version: Uninstalled
Operating System: Windows

Re: Apache has stopped working before I've finished installa

Postby Supercon22 » 08. November 2017 14:16

[Wed Nov 08 13:15:51.674477 2017] [ssl:info] [pid 3700:tid 396] AH01887: Init: Initializing (virtual) servers for SSL
[Wed Nov 08 13:15:51.676477 2017] [ssl:info] [pid 3700:tid 396] AH01914: Configuring server www.example.com:443 for SSL protocol
[Wed Nov 08 13:15:51.676477 2017] [ssl:debug] [pid 3700:tid 396] ssl_engine_init.c(444): AH01893: Configuring TLS extension handling
[Wed Nov 08 13:15:51.677477 2017] [ssl:debug] [pid 3700:tid 396] ssl_util_ssl.c(443): AH02412: [www.example.com:443] Cert does not match for name 'www.example.com' [subject: CN=localhost / issuer: CN=localhost / serial: B5C752C98781B503 / notbefore: Nov 10 23:48:47 2009 GMT / notafter: Nov 8 23:48:47 2019 GMT]
[Wed Nov 08 13:15:51.677477 2017] [ssl:warn] [pid 3700:tid 396] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Nov 08 13:15:51.677477 2017] [ssl:info] [pid 3700:tid 396] AH02568: Certificate and private key www.example.com:443:0 configured from C:/xampp/apache/conf/ssl.crt/server.crt and C:/xampp/apache/conf/ssl.key/server.key
[Wed Nov 08 13:15:51.677477 2017] [ssl:info] [pid 3700:tid 396] AH01876: mod_ssl/2.4.28 compiled against Server: Apache/2.4.28, Library: OpenSSL/1.0.2l

found more info, need this fixing ASAP
Supercon22
 
Posts: 17
Joined: 07. November 2017 00:11
XAMPP version: Uninstalled
Operating System: Windows

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests