After document root change, Apache doesn't run as a service

Problems with the Windows version of XAMPP, questions, comments, and anything related.

After document root change, Apache doesn't run as a service

Postby tlotr » 10. September 2017 13:52

Hi,

I have this problem of Apache does not run as a windows service if the document root path is changed from C:/XAMPP/htdocs.

How can I fix this?

Is this is known issue?
tlotr
 
Posts: 3
Joined: 10. September 2017 13:48
XAMPP version: 3.2.2
Operating System: Windows 10

Re: After document root change, Apache doesn't run as a serv

Postby Altrea » 10. September 2017 17:14

Hi,

you don't provide much information about your issue so it is impossible for me to say anything about it.
Is the new DocumentRoot a path on your local harddrive or a network drive, or a cloud drive, or a usb pen drive?
Is the new path mapped to a windows drive letter?
Is this drive letter read and writable for the Windows user Apache is started with?

Have you tried to get any log messages? => [Q&A] Insufficient debug information - Apache starting issue

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8964
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: After document root change, Apache doesn't run as a serv

Postby tlotr » 11. September 2017 05:36

Hello Altrea,

Sorry about that. It's first time posting in this form.

The path is in the same windows drive "C:/Users/usernamehere/Google Drive/htdocs" instead of C:/Xampp

The XAMPP control panel gives this error message

[Apache] Status change detected: running
[Apache] Status change detected: stopped
[Apache] Error: Apache shutdown unexpectedly.
[Apache] This may be due to a blocked port, missing dependencies,
[Apache] improper privileges, a crash, or a shutdown by another method.
[Apache] Press the Logs button to view error logs and check
[Apache] the Windows Event Viewer for more clues
[Apache] If you need more help, copy and post this
[Apache] entire log window on the forums

There are no logs generated.

Please, let me know if you require any more information.
tlotr
 
Posts: 3
Joined: 10. September 2017 13:48
XAMPP version: 3.2.2
Operating System: Windows 10

Re: After document root change, Apache doesn't run as a serv

Postby Altrea » 11. September 2017 06:24

Hi,

Yes, i require more information.
Read the previously linked thread. Every information needed and in which amount it is needed is listed there.
My guess is that the User Apache is started with does not have sufficient permissions on that Google Drive folder.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8964
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: After document root change, Apache doesn't run as a serv

Postby tlotr » 11. September 2017 18:07

Hi Altrea,

You were right, google drive Administrators user didn't had any access on the google drive folder and hence it was failing.

Thanks for pointing me in the right direction.
tlotr
 
Posts: 3
Joined: 10. September 2017 13:48
XAMPP version: 3.2.2
Operating System: Windows 10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 74 guests