phpmyadmin error after changing PHP version

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpmyadmin error after changing PHP version

Postby NewbieNr1 » 16. July 2017 10:22

I followed this guide installing php version 7.0.21 (from php.net) and changed every path of /php to my newly created php directory /php7-0-21

Use a Different PHP Version
In many cases, you might want to use XAMPP with a different PHP version than the one that comes pre-installed. You might do this to get the benefits of a newer version of PHP, or to reproduce bugs using an earlier version of PHP.

To use a different version of PHP with XAMPP, follow these steps:

Download a binary build of the PHP version that you wish to use from the PHP website, and extract the contents of the compressed archive file to your XAMPP installation directory (usually, C:\xampp). Ensure that you give it a different directory name to avoid overwriting the existing PHP version. For example, in this tutorial, we’ll call the new directory C:\xampp\php5-6-0.

Ensure that the PHP build you download matches the Apache build (VC9 or VC11) in your XAMPP platform.
Within the new directory, rename the php.ini-development file to php.ini. If you prefer to use production settings, you could instead rename the php.ini-production file to php.ini.

Edit the httpd-xampp.conf file in the apache\conf\extra\ subdirectory of your XAMPP installation directory. Within this file, search for all instances of the old PHP directory path and replace them with the path to the new PHP directory created in Step 1.

In particular, be sure to change the lines

LoadFile "/xampp/php/php5ts.dll"
LoadFile "/xampp/php/libpq.dll"
LoadModule php5_module "/xampp/php/php5apache2_4.dll"
to

LoadFile "/xampp/php5-6-0/php5ts.dll"
LoadFile "/xampp/php5-6-0/libpq.dll"
LoadModule php5_module "/xampp/php5-6-0/php5apache2_4.dll"
Remember to adjust the file and directory paths above to reflect valid paths on your system.
Restart your Apache server through the XAMPP control panel for your changes to take effect.

The new version of PHP should now be active. To verify this, browse to the URL http://localhost/xampp/phpinfo.php, which displays the output of the phpinfo() command, and check the version number at the top of the page.


Then when I try to go to phpMyAdmin I get this error:

phpmyadmin error
Extension mysqli is missing.

Any idea?
NewbieNr1
 
Posts: 1
Joined: 16. July 2017 10:14
XAMPP version: 7.1.7
Operating System: Windows 10

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests