PHP 7 Deprecation Error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP 7 Deprecation Error

Postby garima » 31. May 2017 13:09

Hi,

I have updated php version from PHP5.2.4 to PHP Version 7.0.19 , this done perfectly but in phpmyadmin deprecation errors are coming.Please help. Xamp version is v3.2.1

Deprecation Notice in .\libraries\php-gettext\streams.php#48
Methods with the same name as their class will not be constructors in a future version of PHP; StringReader has a deprecated constructor

Backtrace

.\libraries\php-gettext\gettext.inc#41: require()
.\libraries\select_lang.lib.php#471: require_once(.\libraries\php-gettext\gettext.inc)
.\libraries\common.inc.php#564: require(.\libraries\select_lang.lib.php)
.\error_report.php#8: require_once(.\libraries\common.inc.php)
Deprecation Notice in .\libraries\php-gettext\streams.php#84
Methods with the same name as their class will not be constructors in a future version of PHP; FileReader has a deprecated constructor

Backtrace

.\libraries\php-gettext\gettext.inc#41: require()
.\libraries\select_lang.lib.php#471: require_once(.\libraries\php-gettext\gettext.inc)
.\libraries\common.inc.php#564: require(.\libraries\select_lang.lib.php)
.\error_report.php#8: require_once(.\libraries\common.inc.php)
Deprecation Notice in .\libraries\php-gettext\streams.php#145
Methods with the same name as their class will not be constructors in a future version of PHP; CachedFileReader has a deprecated constructor

Backtrace

.\libraries\php-gettext\gettext.inc#41: require()
.\libraries\select_lang.lib.php#471: require_once(.\libraries\php-gettext\gettext.inc)
.\libraries\common.inc.php#564: require(.\libraries\select_lang.lib.php)
.\error_report.php#8: require_once(.\libraries\common.inc.php)
Deprecation Notice in .\libraries\php-gettext\gettext.php#36
Methods with the same name as their class will not be constructors in a future version of PHP; gettext_reader has a deprecated constructor

Backtrace

.\libraries\php-gettext\gettext.inc#42: require()
.\libraries\select_lang.lib.php#471: require_once(.\libraries\php-gettext\gettext.inc)
.\libraries\common.inc.php#564: require(.\libraries\select_lang.lib.php)
.\error_report.php#8: require_once(.\libraries\common.inc.php)
garima
 
Posts: 4
Joined: 26. May 2017 07:01
XAMPP version: 3.2.1
Operating System: windows 7

Re: PHP 7 Deprecation Error

Postby Nobbie » 31. May 2017 17:11

A "notice" is nothing, simply a notice. Not a warning and by far not an error.

If you dont like notices, edit your php.ini and change the error level of error reporting, or totally switch of error reporting. Or install a newer phpmyadmin, maybe the notices will disappear.
Nobbie
 
Posts: 9768
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests