errors when starting apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

errors when starting apache

Postby enthusiast14 » 04. May 2017 15:03

Hi i installed xampp 7.0.15 after getting same error with latest version.
the error is - when i start apache from xampp control panel i get following system alert error - "the program can't start bcoz api-ms-win-crt-runtime-I1-1-0.dll is missing from your computer.Try reinstalling the program to fix this problem"

I reinstalled but same error, i am using windows 7, where is wrong??
enthusiast14
 
Posts: 7
Joined: 04. May 2017 14:58
XAMPP version: 7.0.15
Operating System: windows 7

Re: errors when starting apache

Postby Altrea » 04. May 2017 15:21

Hi,

You need to install Visual C++ Redistributable für Visual Studio 2015 first (use the x86 version, because XAMPP is compiled in 32 bit)

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8879
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: errors when starting apache

Postby enthusiast14 » 04. May 2017 16:06

I downloaded it and tried to install and i get error that installation failed and i see that it says that it was already installed ! what wrong?
enthusiast14
 
Posts: 7
Joined: 04. May 2017 14:58
XAMPP version: 7.0.15
Operating System: windows 7

Re: errors when starting apache

Postby Altrea » 04. May 2017 16:44

Then uninstall it and reinstall it again.
There is no other solution.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8879
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: errors when starting apache

Postby enthusiast14 » 04. May 2017 16:53

not working, is the link u provided the latest version?
enthusiast14
 
Posts: 7
Joined: 04. May 2017 14:58
XAMPP version: 7.0.15
Operating System: windows 7

Re: errors when starting apache

Postby Altrea » 04. May 2017 17:07

You don't need the "latest" version, you need the version Apache is compiled with.
The Apache in XAMPP 7.0.15 is compiled with VC14 x84 (for which you need to install Microsoft Visual C++ 2015 Redistributable x86).
The latest version of VC14 runtime is Update 3, so maybe you want to try this as well: https://www.microsoft.com/en-US/downloa ... x?id=53840
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8879
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: errors when starting apache

Postby enthusiast14 » 04. May 2017 22:48

hahaha not working this update also not installing at last. no solution?!!
enthusiast14
 
Posts: 7
Joined: 04. May 2017 14:58
XAMPP version: 7.0.15
Operating System: windows 7

Re: errors when starting apache

Postby enthusiast14 » 14. May 2017 15:48

I installed windows 7 service pack 1 and reinstalled VC++ software too and i see no errors now.
enthusiast14
 
Posts: 7
Joined: 04. May 2017 14:58
XAMPP version: 7.0.15
Operating System: windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 42 guests