older xampp 1.8.2 php 5.4.27 on WinXPpro, can't add "Deny"

Problems with the Windows version of XAMPP, questions, comments, and anything related.

older xampp 1.8.2 php 5.4.27 on WinXPpro, can't add "Deny"

Postby johnwayne » 27. March 2017 21:57

older xampp 1.8.2 php 5.4.27 on WinXPpro, can't add "Deny from" ip entries to the xampp\apache\conf\httpd.conf file. It causes the server to NOT start.
I checked the log and it is indeed the line in the httpd.conf with the denied ips that causes the failure to start.
is there a limit to how many ip addresses can be listed in the "Deny from"?
Are there any other exceptions that could be causing the added ip addresses to crash the startup? (i.e.: duplicate ip entries, i have quite a few in there, but dont think i have any duplicates)
SEP is blocking frequent attempted struts attacks, and i am attempting to blacklist the offending IPs.
backing out the newest set of denied IPs allows the server to start.

Also, I cannot find any documentation about how to upgrade or patch struts on my installation. I do not run TomCat, i ONLY run the apache server.
johnwayne
 
Posts: 6
Joined: 11. April 2014 23:11
XAMPP version: 1.8.2
Operating System: windows xp pro sp3

Re: older xampp 1.8.2 php 5.4.27 on WinXPpro, can't add "Den

Postby johnwayne » 27. March 2017 22:48

after trial and error, it does not seem to be an IP quantity limit, rather there is the denying of one specific IP address that causes apache not to start: 125.277.38.168
could that attacker have remotely modified my setup so that their IP address could not be blocked?

I will run that IP through IDM's UltraFinder on the xampp directory to see if I can find that IP in code elsewhere..
johnwayne
 
Posts: 6
Joined: 11. April 2014 23:11
XAMPP version: 1.8.2
Operating System: windows xp pro sp3

Re: older xampp 1.8.2 php 5.4.27 on WinXPpro, can't add "Den

Postby johnwayne » 27. March 2017 23:16

omg, i have been looking at code for too long..
.277 is out of range. either typo or misread SEP log.
mystery solved.

now, does anyone know how to update struts on xampp 1.8.2?
johnwayne
 
Posts: 6
Joined: 11. April 2014 23:11
XAMPP version: 1.8.2
Operating System: windows xp pro sp3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 41 guests