ionCube PHP Loader

Problems with the Windows version of XAMPP, questions, comments, and anything related.

ionCube PHP Loader

Postby nesoor » 07. March 2017 23:42

Hello Xampp members,

I put an offline version of my webshop local on my PC for testing.
Prestashop is working but when I try to login in to the admin I get the following error:

Site error: the file C:\xampp\htdocs\modules\tpvtienda\classes\Movimientos.php requires the ionCube PHP Loader ioncube_loader_win_5.6.dll to be installed by the website operator. If you are the website operator please use the ionCube Loader Wizard to assist with installation.
nesoor
 
Posts: 1
Joined: 07. March 2017 23:39
XAMPP version: 5.6.30
Operating System: windows 10

Re: ionCube PHP Loader

Postby Altrea » 08. March 2017 02:11

Hi,

Is this just for information or do you have a specific question?

Ioncube is a third party component, so we cannot assist you installing it.
If you have problems installing Ioncube please search for the Ioncube installation documentation or ask at a Ioncube support channel.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8889
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: ionCube PHP Loader

Postby faospark » 09. March 2017 01:31

download a version of ioncube loader on
ioncube.com/loaders.php
choose just 1 package

Open the zip file and place the ioncube_loader_win_7.0.dll in your [xampp install folder]-> /php -> /ext
(basically the folder where all php extensions are located like opcache.dll, php_ldap.dll)

once you placed the file there open your php.ini file and add the this line
[IonCube]
zend_extension=ioncube_loader_win_7.0.dll

to Check if you IonCube is Loaded on your local server
open the same zip file where you got the dll files. there should be a file named loader-wizard.php
pull or place that on your localhost folder and access it on http://locahost/loader-wizard.php or any location you placed it

just a point to consider: ioncube is still not compatible with PHP version 7.1.1 so you have to downgrade to version 7 if you want to use it
User avatar
faospark
 
Posts: 11
Joined: 07. March 2017 11:40
XAMPP version: 7.1.1
Operating System: windows 10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 39 guests