Problem activating plugin

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem activating plugin

Postby GSLookingForAnswers » 13. February 2017 03:58

I have just installed xammp 7.1.1 on W10 with what I believe is a standard installation with UAC disabled.
Have verified that it is working.

Made following changes to c:\xampp\php\php.ini

post_max_size=1024M
memory_limit=1024M

Installed a new theme and that went well. Installed several plugins that were recommended with mixed results.
When trying to install contact form 7 I receive a fatal error.
Fatal error: Cannot use $this as parameter in C:\xampp\htdocs\wordpress\wp-content\themes\Total\framework\3rd-party\contact-form-7.php on line 37


Is this possibly a problem with xampp?
I have posted into the wordpress/plugin/contact form 7 forum but am not getting any response.

How do I make progress?
thanks for any help.
Gavin
GSLookingForAnswers
 
Posts: 4
Joined: 13. February 2017 03:39
XAMPP version: 5.6.3
Operating System: Windows 10

Re: Problem activating plugin

Postby Altrea » 13. February 2017 10:38

Hi,

Did you check that the Wordpress version you want to use is compatible with PHP 7.1.1?

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8838
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Problem activating plugin

Postby GSLookingForAnswers » 17. February 2017 04:51

That was the problem.

Thanks
GSLookingForAnswers
 
Posts: 4
Joined: 13. February 2017 03:39
XAMPP version: 5.6.3
Operating System: Windows 10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 28 guests