No acces from public IP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

No acces from public IP

Postby crisperfx » 29. January 2017 22:38

Hello,

i installed XAMPP 3.2.2 and was wondering why i cant connect to my xampp server from my public IP.
I forwarded following ports on the router from my ISP: 32400 and 32450 ==> UDP & TCP

I have PLEX with port 32400 open and which i can acces trough my public IP. htpp://publicIP.com:32400 ==> PLEX Works
I have XAMPP with port 32450 open but i can only acces trough local IP. http://publicIP.com:32450 ==> XAMPP does not work

I have tried several ports but nothing works.

Firewall has been shut down. I think i need to edit some config files from XAMPP. Someone who can help me with this?
Thnx in advance! And sorry for my bad english ;)
crisperfx
 
Posts: 6
Joined: 14. May 2015 13:33
XAMPP version: 5.6.28
Operating System: windows 10

Re: No acces from public IP

Postby JJ_Tagy » 30. January 2017 00:24

crisperfx wrote:i installed XAMPP 3.2.2

Nope. No such version.

crisperfx wrote:i cant connect to my xampp server from my public IP.

That is beyond the scope of this board. No support to expose a development platform to the internet.

crisperfx wrote:I forwarded following ports on the router from my ISP: 32400 and 32450 ==> UDP & TCP...I have tried several ports but nothing works...Firewall has been shut down.

Quite dangerous to expose your system to something you don't understand. I recommend reading up on UDP, TCP, HTTP, and common ports.

crisperfx wrote:I think i need to edit some config files from XAMPP.

No. Again, beyond the scope of this board.
JJ_Tagy
 
Posts: 722
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: No acces from public IP

Postby Nobbie » 30. January 2017 12:15

Anyway, Port 32450 looks extremey strange, i think you are mixing up things. Apache usually listens on Port 80 and Port 443.
Nobbie
 
Posts: 9549
Joined: 09. March 2008 13:04

Re: No acces from public IP

Postby crisperfx » 30. January 2017 12:43

Nobbie wrote:Anyway, Port 32450 looks extremey strange, i think you are mixing up things. Apache usually listens on Port 80 and Port 443.

My ISP blocked several ports so we cannot use them. I changed my apache port in file httpd.conf to 32450 so locally i have http://localhost:32450/ and this works ;)

Only from public ip i couldn't get any connection. But i already figured it out, by editing the httpd-vhosts.conf file. By adding a virtual host with option Require all granted
Also to protect my system integrity i made some .htpasswd files so only with a login you can access any files.
Thank you anyway for the help!
crisperfx
 
Posts: 6
Joined: 14. May 2015 13:33
XAMPP version: 5.6.28
Operating System: windows 10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 29 guests