Xampp very slow and Apache's port

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp very slow and Apache's port

Postby argie01 » 27. January 2017 16:42

Hi,

I´running Xampp in Windows 10. Firewall in local lan is disabled.
But when I try to work with something as simple as a Wordpress the load speed is very slow, and sometime I got nothing: blank page.

Also I see that suddenly Apache starts ports are by default: 80 and 443. But after few seconds they change to one or several ports: 61145, or 34543,22345,54321 (or similar)
I found it very strange and perhaps it's relating to the problem of get a blank page...

Thank you for your help.
argie01
 
Posts: 29
Joined: 19. July 2004 19:17

Re: Xampp very slow and Apache's port

Postby Nobbie » 27. January 2017 19:06

argie01 wrote:But when I try to work with something as simple as a Wordpress


Are you kidding?? WordPress is neither simple nor something else, its a horrible ressource burner and there are thousands and thousand of issues in the WWW about a slow WordPress installation. What makes you believe, that WordPress is "simple"??
Nobbie
 
Posts: 9569
Joined: 09. March 2008 13:04

Re: Xampp very slow and Apache's port

Postby argie01 » 03. February 2017 17:29

That's not the point Nobbie.
The point is it seems there are problems with Apache ports in my Xampp.
argie01
 
Posts: 29
Joined: 19. July 2004 19:17

Re: Xampp very slow and Apache's port

Postby Nobbie » 03. February 2017 18:31

argie01 wrote:That's not the point Nobbie.
The point is it seems there are problems with Apache ports in my Xampp.


No, its not.
Nobbie
 
Posts: 9569
Joined: 09. March 2008 13:04

Re: Xampp very slow and Apache's port

Postby gsmith » 03. February 2017 20:03

Argie, Apache only listens on 80 & 443 but sends the response on a different port. It has to so 80 can stay free for other requests.

See the first 2 paragraphs at http://httpd.apache.org/docs/2.4/bind.html
gsmith
 
Posts: 211
Joined: 29. November 2013 18:04
Location: San Diego
XAMPP version: 0.0.0
Operating System: Win XP to 2012R2/VS 6,9,11,14

Re: Xampp very slow and Apache's port

Postby argie01 » 06. February 2017 20:24

Thanks gsmith. I know it.
Precisely that's my question: why Xampp Control Panel is showing 80,443 for Apache, and suddenly it changes to 50152, 51244, and so on? Because in the exact moment when this change happens, my WP can't load and returns error.

Thank you.
argie01
 
Posts: 29
Joined: 19. July 2004 19:17

Re: Xampp very slow and Apache's port

Postby Nobbie » 06. February 2017 20:39

argie01 wrote: Because in the exact moment when this change happens, my WP can't load and returns error.


That looks like a firewall (or similar tools) issue.
Nobbie
 
Posts: 9569
Joined: 09. March 2008 13:04

Re: Xampp very slow and Apache's port

Postby JJ_Tagy » 07. February 2017 03:14

argie01 wrote:why Xampp Control Panel is showing 80,443 for Apache, and suddenly it changes to 50152, 51244, and so on?

Because the control panel is limited in its capability. It shows what ports it is active - not just what it is listening. If you are really interested do some research on how the system hands off connections.
JJ_Tagy
 
Posts: 723
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests