apache stopped working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

apache stopped working

Postby cath999 » 25. January 2017 19:19

HI,

Yesterday as I was installing Apache and MySql both were working. Now only MySql is working. Cannot make Apache work. Have logged in as Administrator. There seems to be no problem.
Please advise me what to do:
12:13:22 PM [main] Initializing Control Panel
12:13:22 PM [main] Windows Version: Home 64-bit
12:13:22 PM [main] XAMPP Version: 5.6.28
12:13:22 PM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
12:13:22 PM [main] You are not running with administrator rights! This will work for
12:13:22 PM [main] most application stuff but whenever you do something with services
12:13:22 PM [main] there will be a security dialogue or things will break! So think
12:13:22 PM [main] about running this application with administrator rights!
12:13:22 PM [main] XAMPP Installation Directory: "c:\users\owner\documents\xampp\"
12:13:22 PM [main] Checking for prerequisites
12:13:27 PM [main] All prerequisites found
12:13:27 PM [main] Initializing Modules
12:13:27 PM [main] The FileZilla module is disabled
12:13:27 PM [main] The Mercury module is disabled
12:13:27 PM [main] The Tomcat module is disabled
12:13:27 PM [main] Starting Check-Timer
12:13:27 PM [main] Control Panel Ready
12:13:30 PM [Apache] Attempting to start Apache app...
12:13:30 PM [Apache] Status change detected: running
12:13:32 PM [Apache] Status change detected: stopped
12:13:32 PM [Apache] Error: Apache shutdown unexpectedly.
12:13:32 PM [Apache] This may be due to a blocked port, missing dependencies,
12:13:32 PM [Apache] improper privileges, a crash, or a shutdown by another method.
12:13:32 PM [Apache] Press the Logs button to view error logs and check
12:13:32 PM [Apache] the Windows Event Viewer for more clues
12:13:32 PM [Apache] If you need more help, copy and post this
12:13:32 PM [Apache] entire log window on the forums
12:13:32 PM [mysql] Attempting to start MySQL app...
12:13:36 PM [Apache] Attempting to start Apache app...
12:13:36 PM [Apache] Status change detected: running
12:13:36 PM [mysql] Status change detected: running
12:13:37 PM [Apache] Status change detected: stopped
12:13:37 PM [Apache] Error: Apache shutdown unexpectedly.
12:13:37 PM [Apache] This may be due to a blocked port, missing dependencies,
12:13:37 PM [Apache] improper privileges, a crash, or a shutdown by another method.
12:13:37 PM [Apache] Press the Logs button to view error logs and check
12:13:37 PM [Apache] the Windows Event Viewer for more clues
12:13:37 PM [Apache] If you need more help, copy and post this
12:13:37 PM [Apache] entire log window on the forums
12:13:38 PM [Apache] Attempting to start Apache app...
12:13:38 PM [Apache] Status change detected: running
12:13:40 PM [Apache] Status change detected: stopped
12:13:40 PM [Apache] Error: Apache shutdown unexpectedly.
12:13:40 PM [Apache] This may be due to a blocked port, missing dependencies,
12:13:40 PM [Apache] improper privileges, a crash, or a shutdown by another method.
12:13:40 PM [Apache] Press the Logs button to view error logs and check
12:13:40 PM [Apache] the Windows Event Viewer for more clues
12:13:40 PM [Apache] If you need more help, copy and post this
12:13:40 PM [Apache] entire log window on the forums
12:13:47 PM [Apache] Attempting to start Apache app...
12:13:47 PM [Apache] Status change detected: running
12:13:49 PM [Apache] Status change detected: stopped
12:13:49 PM [Apache] Error: Apache shutdown unexpectedly.
12:13:49 PM [Apache] This may be due to a blocked port, missing dependencies,
12:13:49 PM [Apache] improper privileges, a crash, or a shutdown by another method.
12:13:49 PM [Apache] Press the Logs button to view error logs and check
12:13:49 PM [Apache] the Windows Event Viewer for more clues
12:13:49 PM [Apache] If you need more help, copy and post this
12:13:49 PM [Apache] entire log window on the forums
12:20:54 PM [main] Executing "c:\users\owner\documents\xampp\"
12:21:17 PM [main] Executing "services.msc"
cath999
 
Posts: 4
Joined: 25. January 2017 19:01
XAMPP version: 3.2.2
Operating System: windows 10

Re: apache stopped working

Postby Altrea » 25. January 2017 23:43

Hi,

cath999 wrote:12:13:22 PM [main] XAMPP Version: 5.6.28

This is your XAMPP version, not the one you entered in your forum profile. Please update that information in your forum profile settings.

cath999 wrote:12:13:22 PM [main] XAMPP Installation Directory: "c:\users\owner\documents\xampp\"

Please don't use your local User folder as installation path. Using the default C:\xampp\ path is highly recommend.

There are way more information you can gather to identify the reason for this issue.
Please read this thread: [Q&A] Insufficient debug information - Apache starting issue

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8766
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: apache stopped working

Postby cath999 » 26. January 2017 21:57

I reinstalled the program so now it works. Thank you for pointing out where the problem was
cath999
 
Posts: 4
Joined: 25. January 2017 19:01
XAMPP version: 3.2.2
Operating System: windows 10

Re: apache stopped working

Postby cath999 » 28. January 2017 12:44

The instructor of the course I have enrolled in asked me to reinstall everything. So I did and now nothing work as it should:
6:43:53 AM [main] Initializing Control Panel
6:43:53 AM [main] Windows Version: Home 64-bit
6:43:53 AM [main] XAMPP Version: 5.6.28
6:43:53 AM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
6:43:53 AM [main] You are not running with administrator rights! This will work for
6:43:53 AM [main] most application stuff but whenever you do something with services
6:43:53 AM [main] there will be a security dialogue or things will break! So think
6:43:53 AM [main] about running this application with administrator rights!
6:43:53 AM [main] XAMPP Installation Directory: "c:\users\owner\documents\xampp\"
6:43:53 AM [main] Checking for prerequisites
6:43:53 AM [main] All prerequisites found
6:43:53 AM [main] Initializing Modules
6:43:53 AM [main] The FileZilla module is disabled
6:43:53 AM [main] The Mercury module is disabled
6:43:53 AM [main] The Tomcat module is disabled
6:43:53 AM [main] Starting Check-Timer
6:43:53 AM [main] Control Panel Ready
6:43:57 AM [Apache] Attempting to start Apache app...
6:43:57 AM [Apache] Status change detected: running
6:43:58 AM [Apache] Status change detected: stopped
6:43:58 AM [Apache] Error: Apache shutdown unexpectedly.
6:43:58 AM [Apache] This may be due to a blocked port, missing dependencies,
6:43:58 AM [Apache] improper privileges, a crash, or a shutdown by another method.
6:43:58 AM [Apache] Press the Logs button to view error logs and check
6:43:58 AM [Apache] the Windows Event Viewer for more clues
6:43:58 AM [Apache] If you need more help, copy and post this
6:43:58 AM [Apache] entire log window on the forums
6:44:00 AM [mysql] Attempting to start MySQL app...

He asked me to ask you in the Xampp forum for what is wrong and if you can tell me how to fix this?
Apache briefly starts and then stops and MySql does not even start.

Thank you
cath999
 
Posts: 4
Joined: 25. January 2017 19:01
XAMPP version: 3.2.2
Operating System: windows 10

Re: apache stopped working

Postby Altrea » 28. January 2017 12:55

Well, then please start here to provide us much more information:
=> [Q&A] Apache won't start
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8766
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: apache stopped working

Postby cath999 » 29. January 2017 15:35

I should mention I AM logged in as Administrator.
This is the log error message I see for My Sql:
2015-11-10 15:26:56 10fc InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
2015-11-10 15:26:56 4348 [Note] InnoDB: Using mutexes to ref count buffer pool pages
2015-11-10 15:26:56 4348 [Note] InnoDB: The InnoDB memory heap is disabled
2015-11-10 15:26:56 4348 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2015-11-10 15:26:56 4348 [Note] InnoDB: Memory barrier is not used
2015-11-10 15:26:56 4348 [Note] InnoDB: Compressed tables use zlib 1.2.3
2015-11-10 15:26:56 4348 [Note] InnoDB: Not using CPU crc32 instructions
2015-11-10 15:26:56 4348 [Note] InnoDB: Initializing buffer pool, size = 16.0M
2015-11-10 15:26:56 4348 [Note] InnoDB: Completed initialization of buffer pool
2015-11-10 15:26:56 4348 [Note] InnoDB: Highest supported file format is Barracuda.
2015-11-10 15:26:57 4348 [Note] InnoDB: 128 rollback segment(s) are active.
2015-11-10 15:26:57 4348 [Note] InnoDB: Waiting for purge to start
2015-11-10 15:26:57 4348 [Note] InnoDB: Percona XtraDB (http://www.percona.com) 5.6.26-74.0 started; log sequence number 1835027
2015-11-10 15:26:57 6140 [Note] InnoDB: Dumping buffer pool(s) not yet started
2015-11-10 15:26:57 4348 [Note] Plugin 'FEEDBACK' is disabled.
2015-11-10 15:26:57 4348 [Note] Server socket created on IP: '::'.
2015-11-10 15:26:57 4348 [Note] Event Scheduler: Loaded 0 events
2015-11-10 15:26:57 4348 [Note] C:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '10.1.8-MariaDB' socket: '' port: 3306 mariadb.org binary distribution
2015-11-10 15:27:11 5152 [Note] C:\xampp\mysql\bin\mysqld.exe: Normal shutdown

2015-11-10 15:27:11 5152 [Note] Event Scheduler: Purging the queue. 0 events
2015-11-10 15:27:11 5732 [Note] InnoDB: FTS optimize thread exiting.
2015-11-10 15:27:11 5152 [Note] InnoDB: Starting shutdown...
2015-11-10 15:27:13 5152 [Note] InnoDB: Shutdown completed; log sequence number 1835037
2015-11-10 15:27:13 5152 [Note] C:\xampp\mysql\bin\mysqld.exe: Shutdown complete

I am just a novice trying to install Wordpress on my computer. Having problems doing so.
Any advice about what I need to do will be welcomed.
cath999
 
Posts: 4
Joined: 25. January 2017 19:01
XAMPP version: 3.2.2
Operating System: windows 10

Re: apache stopped working

Postby Altrea » 29. January 2017 18:45

cath999 wrote:I should mention I AM logged in as Administrator.

It is a difference to be logged in as a Windows user with administratior rights or to start a program with elevated administration rights.

cath999 wrote:Any advice about what I need to do will be welcomed.

I already told you what to do. Read and follow the linked thread carefully.
You still don't provide us the needed information.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8766
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests