Port 80 error while starting Apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Port 80 error while starting Apache

Postby joanna » 25. January 2017 08:55

Hi,

it's my first time using Xampp and I have problem with starting Apache. I have started MySQL and Tomcat without problems but when I try to start Apache I got the following error message:

08:46:56 [Apache] Error: Apache shutdown unexpectedly.
08:46:56 [Apache] This may be due to a blocked port, missing dependencies,
08:46:56 [Apache] improper privileges, a crash, or a shutdown by another method.
08:52:38 [Apache] Problem detected!
08:52:38 [Apache] Port 80 in use by "Unable to open process" with PID 4!
08:52:38 [Apache] Apache WILL NOT start without the configured ports free!
08:52:38 [Apache] You need to uninstall/disable/reconfigure the blocking application
08:52:38 [Apache] or reconfigure Apache and the Control Panel to listen on a different port

Where I can find the application that is blocking Port 80? I checked logs and they are empty.

I would appreciate your help.
joanna
 
Posts: 1
Joined: 25. January 2017 08:49
XAMPP version: 3.2.2
Operating System: Windows 10

Re: Port 80 error while starting Apache

Postby phantomitch » 30. January 2017 02:30

Do you have Skype in your machine?
The problem with SKYPE is that it also uses port 80 and 443.
try changing the port used by skype to 8080 in connection options menu
in skype.

Let me know what happened.

Regards
phantomitch
 
Posts: 2
Joined: 30. January 2017 02:23
XAMPP version: 3.2.2
Operating System: windows 10

Re: Port 80 error while starting Apache

Postby JJ_Tagy » 30. January 2017 18:22

Skype won't use system pid 4.
JJ_Tagy
 
Posts: 727
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 34 guests