Website displays properly locally and remotely, but...

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Website displays properly locally and remotely, but...

Postby Asatani » 15. January 2017 19:20

I am running XAMPP 5.6 and experiencing a weird issue. If I preview my website locally (http://localhost/), it works as intended, all content is displayed. If I ask someone outside my network to view it (http://my.exte.rnal.ip/), their screenshot shows it to be working as intended, all content displayed. If I try to access it from another computer on my network (both http://my.inte.rnal.ip/ and http://my.exte.rnal.ip/), only text and table data are displayed, all images are broken and no scripts run. I want to edit and preview my website without having to be at my server computer, so this is issue is pretty inconvenient. Is there anything I can do to fix this?

Just to clarify, all of my content uses relative pathing, not absolute. Everything displays correctly from outside my network, just like it does when viewed locally.
Asatani
 
Posts: 1
Joined: 15. January 2017 19:07
XAMPP version: 5.6
Operating System: Win7

Re: Website displays properly locally and remotely, but...

Postby Altrea » 16. January 2017 02:02

Use a debugging tool like Firefox Firebug, Chrome Developer Tools or something similar to display all requests and their responses.
Especially interesting informations are Which ressource URLs are used and Which HTTP Status codes are responded.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8845
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Website displays properly locally and remotely, but...

Postby Nobbie » 16. January 2017 11:50

The only thing which comes to mind: maybe you have some certain "Require" (or "Allow From") Clauses in your Apache configuration, which denies access from inside your LAN. You should find out it anyway via studying the access log and the error log. And/or there might be some similar rules in your local firewall.
Nobbie
 
Posts: 9562
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests