Apache won't start (not answered in sticky)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache won't start (not answered in sticky)

Postby Xyzzyx » 13. January 2017 05:17

I have read the sticky <a href="https://community.apachefriends.org/f/viewtopic.php?f=16&t=69784#p239058">Apache won't start</a> and it helped until it didn't.

First, when starting a fresh install of XAMPP (running as admin!) I was getting the error
Code: Select all
Port 80 in use by "Unable to open process" with PID 4!
, and this appears to have been fixed with the first solution, 'Configure HTTP.sys to only bind to IP v6'. So this initial problem appears to be solved.

However, following that we run into the current problem.

Now (again running as admin) I get the following error, which is not explained how to troubleshoot in the sticky post mentioned above:
Code: Select all
4:38:16 p.m.  [main]    Initializing Control Panel
4:38:16 p.m.  [main]    Windows Version: Windows 7 Professional SP1 64-bit
4:38:16 p.m.  [main]    XAMPP Version: 5.6.28
4:38:16 p.m.  [main]    Control Panel Version: 3.2.2  [ Compiled: Nov 12th 2015 ]
4:38:16 p.m.  [main]    Running with Administrator rights - good!
4:38:16 p.m.  [main]    XAMPP Installation Directory: "f:\xampp\"
4:38:16 p.m.  [main]    Checking for prerequisites
4:38:16 p.m.  [main]    All prerequisites found
4:38:16 p.m.  [main]    Initializing Modules
4:38:16 p.m.  [main]    The FileZilla module is disabled
4:38:16 p.m.  [main]    The Mercury module is disabled
4:38:16 p.m.  [main]    The Tomcat module is disabled
4:38:16 p.m.  [main]    Starting Check-Timer
4:38:16 p.m.  [main]    Control Panel Ready
4:38:22 p.m.  [Apache]    Attempting to start Apache app...
4:38:23 p.m.  [Apache]    Status change detected: running
4:38:27 p.m.  [Apache]    Status change detected: stopped
4:38:27 p.m.  [Apache]    Error: Apache shutdown unexpectedly.
4:38:27 p.m.  [Apache]    This may be due to a blocked port, missing dependencies,
4:38:27 p.m.  [Apache]    improper privileges, a crash, or a shutdown by another method.
4:38:27 p.m.  [Apache]    Press the Logs button to view error logs and check
4:38:27 p.m.  [Apache]    the Windows Event Viewer for more clues
4:38:27 p.m.  [Apache]    If you need more help, copy and post this
4:38:27 p.m.  [Apache]    entire log window on the forums


...and nothing more specific.
The error.log file:
Code: Select all
[Fri Jan 13 16:38:25.320961 2017] [ssl:warn] [pid 2936:tid 256] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Jan 13 16:38:25.492561 2017] [ssl:warn] [pid 2936:tid 256] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Jan 13 16:38:26.412962 2017] [mpm_winnt:notice] [pid 2936:tid 256] AH00455: Apache/2.4.23 (Win32) OpenSSL/1.0.2h PHP/5.6.28 configured -- resuming normal operations
[Fri Jan 13 16:38:26.412962 2017] [mpm_winnt:notice] [pid 2936:tid 256] AH00456: Apache Lounge VC11 Server built: Jul  7 2016 11:13:22
[Fri Jan 13 16:38:26.412962 2017] [core:notice] [pid 2936:tid 256] AH00094: Command line: 'f:\\xampp\\apache\\bin\\httpd.exe -d F:/xampp/apache'
[Fri Jan 13 16:38:26.412962 2017] [mpm_winnt:notice] [pid 2936:tid 256] AH00418: Parent: Created child process 3672
[Fri Jan 13 16:38:26.865363 2017] [ssl:warn] [pid 3672:tid 268] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Jan 13 16:38:27.005764 2017] [ssl:warn] [pid 3672:tid 268] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Jan 13 16:38:27.036964 2017] [mpm_winnt:crit] [pid 3672:tid 268] (OS 109)The pipe has been ended.  : AH00404: Child: Unable to read socket data from parent
[Fri Jan 13 16:38:27.036964 2017] [mpm_winnt:crit] [pid 2936:tid 256] AH00427: Parent: child process 3672 exited with status 3 -- Aborting.


What to do now?
User avatar
Xyzzyx
 
Posts: 10
Joined: 14. March 2013 09:17
Operating System: Windows 7 Pro

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests