Reinstalled XAMPP using 7.0.13 / PHP version

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Reinstalled XAMPP using 7.0.13 / PHP version

Postby Santi87 » 10. January 2017 00:07

I had to reinstall XAMPP and I downloaded the version mentioned above. When I run XAMPP nothing runs. So I go to xampp-contol.exe and run it as administrator. MySql runs but Apache does not. This is what I get from the screen:

5:59:44 PM [main] Initializing Control Panel
5:59:44 PM [main] Windows Version: Home 64-bit
5:59:44 PM [main] XAMPP Version: 7.0.13
5:59:44 PM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
5:59:44 PM [main] Running with Administrator rights - good!
5:59:44 PM [main] XAMPP Installation Directory: "c:\xampp\"
5:59:44 PM [main] Checking for prerequisites
5:59:44 PM [main] All prerequisites found
5:59:44 PM [main] Initializing Modules
5:59:44 PM [Apache] Problem detected!
5:59:44 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
5:59:44 PM [Apache] Apache WILL NOT start without the configured ports free!
5:59:44 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:59:44 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:59:44 PM [mysql] MySQL Service detected with wrong path
5:59:44 PM [mysql] Change XAMPP MySQL and Control Panel settings or
5:59:44 PM [mysql] Uninstall/disable the other service manually first
5:59:44 PM [mysql] Found Path: "C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld" --defaults-file="C:\Program Files\MySQL\MySQL Server 5.1\my.ini" MySQL
5:59:44 PM [mysql] Expected Path: c:\xampp\mysql\bin\mysqld.exe --defaults-file=c:\xampp\mysql\bin\my.ini mysql
5:59:44 PM [mysql] Problem detected!
5:59:44 PM [mysql] Port 3306 in use by ""C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld" --defaults-file="C:\Program Files\MySQL\MySQL Server 5.1\my.ini" MySQL"!
5:59:44 PM [mysql] MySQL WILL NOT start without the configured ports free!
5:59:44 PM [mysql] You need to uninstall/disable/reconfigure the blocking application
5:59:44 PM [mysql] or reconfigure MySQL and the Control Panel to listen on a different port
5:59:44 PM [filezilla] XAMPP FileZilla is already running on port 21
5:59:44 PM [filezilla] XAMPP FileZilla is already running on port 14147
5:59:44 PM [main] The Mercury module is disabled
5:59:44 PM [main] The Tomcat module is disabled
5:59:44 PM [main] Starting Check-Timer
5:59:44 PM [main] Control Panel Ready
5:59:55 PM [Apache] Problem detected!
5:59:55 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
5:59:55 PM [Apache] Apache WILL NOT start without the configured ports free!
5:59:55 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:59:55 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:59:55 PM [Apache] Attempting to start Apache app...
5:59:55 PM [Apache] Status change detected: running
5:59:55 PM [Apache] Status change detected: stopped
5:59:55 PM [Apache] Error: Apache shutdown unexpectedly.
5:59:55 PM [Apache] This may be due to a blocked port, missing dependencies,
5:59:55 PM [Apache] improper privileges, a crash, or a shutdown by another method.
5:59:55 PM [Apache] Press the Logs button to view error logs and check
5:59:55 PM [Apache] the Windows Event Viewer for more clues
5:59:55 PM [Apache] If you need more help, copy and post this
5:59:55 PM [Apache] entire log window on the forums
6:09:05 PM [Apache] Problem detected!
6:09:05 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
6:09:05 PM [Apache] Apache WILL NOT start without the configured ports free!
6:09:05 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
6:09:05 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
6:09:05 PM [Apache] Attempting to start Apache app...
6:09:06 PM [Apache] Status change detected: running
6:09:06 PM [Apache] Status change detected: stopped
6:09:06 PM [Apache] Error: Apache shutdown unexpectedly.
6:09:06 PM [Apache] This may be due to a blocked port, missing dependencies,
6:09:06 PM [Apache] improper privileges, a crash, or a shutdown by another method.
6:09:06 PM [Apache] Press the Logs button to view error logs and check
6:09:06 PM [Apache] the Windows Event Viewer for more clues
6:09:06 PM [Apache] If you need more help, copy and post this
6:09:06 PM [Apache] entire log window on the forums

Now the only thing I have installed that may be causing the issue is Microsoft Web Matrix. I wanted to keep it on if the XAMPP instalation did not work properly. If this is the issue is there a way around not unistalling Web Matrix or do I need to uninstall. Thank you in advance. Santia
Santi87
 
Posts: 6
Joined: 07. October 2016 17:49
XAMPP version: 3.2.2
Operating System: Windows

Re: Reinstalled XAMPP using 7.0.13 / PHP version

Postby Nobbie » 10. January 2017 12:41

Santi87 wrote:Now the only thing I have installed that may be causing the issue is Microsoft Web Matrix


Maybe, but i dont know, which tools are included in WebMatrix. Your PC also has Microsoft IIS (a webserver) running, that is the cause for "Port 80 in use by "Unable to open process" with PID 4!" and your PC already runs a MySQL Installation, that is the cause for "Port 3306 in use by ""C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld" --defaults-file="C:\Program Files\MySQL\MySQL Server 5.1\my.ini" MySQL"!".

You definately heavily overloaded your PC by foreign software which collides with Xampp, now you have multiple Webservers installed, multiple SQL Servers installed, multiple PHP versions installed. You have to de-install ALL that stuff in order to run Xampp. It might be easier to install a fresh Windows.
Nobbie
 
Posts: 9683
Joined: 09. March 2008 13:04

Re: Reinstalled XAMPP using 7.0.13 / PHP version

Postby Santi87 » 10. January 2017 23:22

WebMatrix includes: Microsoft WebMatrix 3, IIS 8.0 Express, IIS Express Application Compatibility Database for x64, IIS Express Application Compatibility Database for x86, Microsoft SQL Server 2012 Data-Tier App Framework (twice installed), Microsoft SQL Server 2012 Transact-SQL ScriptDom, Microsoft System CLR Types for SQL Server 2012, Microsoft Sustem CLR Types for SQL Server 2012 (x64), Microsoft Web Deploy 3.5, and Microsoft Web Platform Installer 5.0.

Went I went into the Command Prompt to look at the list of listeners for TCP/IP I found that port 80 is being held up by PID 4 and what is holding that up is NT Kernel and System. When I open the file location it shows me a file that I cannot get into so I cannot disable it. Could this be attached to WebMatrix?

I installed WebMatrix back in October of last year for a class that I was taking online. The new class that I am taking now is using XAMPP. I used to work with XAMPP and had no problems downloading it the very first time, that was quite a few years ago, but then my hard drive gave way and I forgot how to install it.

Since WebMatrix is working, should I just keep using that until the end of my class and then proceed to switch over to XAMPP, or would it be better to just switch over now and avoid the hassels later. Thank you
Santi87
 
Posts: 6
Joined: 07. October 2016 17:49
XAMPP version: 3.2.2
Operating System: Windows

Re: Reinstalled XAMPP using 7.0.13 / PHP version

Postby Altrea » 11. January 2017 00:31

We cannot choose for you. We can only show you the possibilities:
https://www.devside.net/wamp-server/run ... b-platform
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8930
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 71 guests