WordPress media file upload with Æ Ø Å

Problems with the Windows version of XAMPP, questions, comments, and anything related.

WordPress media file upload with Æ Ø Å

Postby janh84 » 14. December 2016 13:25

Hello. I'm asking here since I've had no luck asking on the official wordpress.org forum ( https://wordpress.org/support/topic/media-upload-filenames-with-foreign-letters-creates-blank-thumbnail/ ) and on StackOverflow ( http://stackoverflow.com/questions/40685147/wordpress-media-upload-filenames-with-foreign-letters-creates-blank-thumbnail )

Everytime I try to upload an image to WordPress that has Æ, Ø or Å the thumbnail shows a placeholder default thumbnail instead of the real image. This happens on a complete new WP install ( xampp localhost ) and it doesn't matter if its WordPress version 4.6.1 or 4.7 and doesnt matter if it's running TwentySixteen or TwentySeventeen theme.

I also tried different MySQL database schemas ( utf8-danish, utf16-danish ) and this doesn't help any bit.

So im starting to believe that the problem is on my XAMPP configuration somewhere.

Please need any advice on what to try from here. Different database schema maybe? Different php.ini settings? Or anything else?
janh84
 
Posts: 1
Joined: 14. December 2016 13:10
XAMPP version: 3.2.2
Operating System: Windows 10

Re: WordPress media file upload with Æ Ø Å

Postby Nobbie » 14. December 2016 22:14

janh84 wrote: Or anything else?


Dont use Xampp.

There are couple of different distributions, you also might install Apache etc. from scratch. In my mind, its not due to Xampp, but to be safe, exclude Xampp. I personally believe that it is a problem in your filesystem, as such characters are not supported in all filesystems. I would not use special characters in filenames, that always has been a problem in internet services.
Nobbie
 
Posts: 9764
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: Nobbie and 32 guests