Filezilla heavy lag after login spam

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Filezilla heavy lag after login spam

Postby Ishutaru » 04. December 2016 22:18

Hello forum, I have a problem with XAMPP 5.6.28. I created an FTP with filezilla (local ftp). At first it works great, fast login, file transfer, able to login from browser, explorer and filezilla program. This is how log looks like when I login(clean log, just the login part):
Code: Select all
FileZilla Server version 0.9.41 beta
Copyright 2001-2012 by Tim Kosse (tim.kosse@filezilla-project.org)
Connecting to server...
Connected, waiting for authentication
Logged on
(000002)2016.12.04 22:59:07 - (not logged in) (127.0.0.1)> Connected, sending welcome message...
(000002)2016.12.04 22:59:07 - (not logged in) (127.0.0.1)> 220 FTP Server
(000002)2016.12.04 22:59:07 - (not logged in) (127.0.0.1)> USER admin
(000002)2016.12.04 22:59:07 - (not logged in) (127.0.0.1)> 331 Password required for admin
(000002)2016.12.04 22:59:07 - (not logged in) (127.0.0.1)> PASS **********
(000002)2016.12.04 22:59:07 - admin (127.0.0.1)> 230 Logged on
(000002)2016.12.04 22:59:07 - admin (127.0.0.1)> opts utf8 on
(000002)2016.12.04 22:59:07 - admin (127.0.0.1)> 200 UTF8 mode enabled
(000002)2016.12.04 22:59:07 - admin (127.0.0.1)> PWD
(000002)2016.12.04 22:59:07 - admin (127.0.0.1)> 257 "/" is current directory.
(000002)2016.12.04 22:59:07 - admin (127.0.0.1)> TYPE A
(000002)2016.12.04 22:59:07 - admin (127.0.0.1)> 200 Type set to A
(000002)2016.12.04 22:59:07 - admin (127.0.0.1)> PASV
(000002)2016.12.04 22:59:07 - admin (127.0.0.1)> 227 Entering Passive Mode (127,0,0,1,202,27)
(000002)2016.12.04 22:59:07 - admin (127.0.0.1)> LIST
(000002)2016.12.04 22:59:07 - admin (127.0.0.1)> 150 Connection accepted
(000002)2016.12.04 22:59:07 - admin (127.0.0.1)> 226 Transfer OK


I created an user admin with a password. It takes few milliseconds to connect to ftp. When I try to login without a password, it prompts me asking for a password. BUT if I don't type a password and click login for few times in a row just by pressing "Enter"(usually 4-8) the filezilla server hangs for a moment and then starts to lag heavily (actually it doesn't matter what you type in login or password, the server starts to lag after you try to spam login few times). This is how log looks like after I do this stunt:
Code: Select all
FileZilla Server version 0.9.41 beta
Copyright 2001-2012 by Tim Kosse (tim.kosse@filezilla-project.org)
Connecting to server...
Connected, waiting for authentication
Logged on
(000015)2016.12.04 23:07:53 - (not logged in) (127.0.0.1)> Connected, sending welcome message...
(000015)2016.12.04 23:07:53 - (not logged in) (127.0.0.1)> 220 FTP Server
(000015)2016.12.04 23:07:59 - (not logged in) (127.0.0.1)> USER admin
(000015)2016.12.04 23:07:59 - (not logged in) (127.0.0.1)> 331 Password required for admin
(000015)2016.12.04 23:08:05 - (not logged in) (127.0.0.1)> PASS **********
(000015)2016.12.04 23:08:05 - admin (127.0.0.1)> 230 Logged on
(000015)2016.12.04 23:08:13 - admin (127.0.0.1)> opts utf8 on
(000015)2016.12.04 23:08:13 - admin (127.0.0.1)> 200 UTF8 mode enabled
(000015)2016.12.04 23:08:13 - admin (127.0.0.1)> PWD
(000015)2016.12.04 23:08:13 - admin (127.0.0.1)> 257 "/" is current directory.
(000015)2016.12.04 23:08:13 - admin (127.0.0.1)> CWD /
(000015)2016.12.04 23:08:13 - admin (127.0.0.1)> 250 CWD successful. "/" is current directory.
(000015)2016.12.04 23:08:13 - admin (127.0.0.1)> TYPE A
(000015)2016.12.04 23:08:13 - admin (127.0.0.1)> 200 Type set to A
(000015)2016.12.04 23:08:13 - admin (127.0.0.1)> PASV
(000015)2016.12.04 23:08:13 - admin (127.0.0.1)> 227 Entering Passive Mode (127,0,0,1,202,50)
(000015)2016.12.04 23:08:13 - admin (127.0.0.1)> LIST
(000015)2016.12.04 23:08:13 - admin (127.0.0.1)> 150 Connection accepted
(000015)2016.12.04 23:08:13 - admin (127.0.0.1)> 226 Transfer OK


Look at the time. There is a delay. It took 20s to login to local ftp from the same computer. If I try logging in with another user like guest user I have created, it also does it really slow:
Code: Select all
(000021)2016.12.04 23:14:22 - (not logged in) (127.0.0.1)> Connected, sending welcome message...
(000021)2016.12.04 23:14:22 - (not logged in) (127.0.0.1)> 220 FTP Server
(000021)2016.12.04 23:14:28 - (not logged in) (127.0.0.1)> USER guest
(000021)2016.12.04 23:14:28 - (not logged in) (127.0.0.1)> 331 Password required for guest
(000021)2016.12.04 23:14:34 - (not logged in) (127.0.0.1)> PASS
(000021)2016.12.04 23:14:34 - guest (127.0.0.1)> 230 Logged on
(000021)2016.12.04 23:14:42 - guest (127.0.0.1)> SYST
(000021)2016.12.04 23:14:42 - guest (127.0.0.1)> 215 UNIX emulated by FileZilla
(000021)2016.12.04 23:14:42 - guest (127.0.0.1)> PWD
(000021)2016.12.04 23:14:42 - guest (127.0.0.1)> 257 "/" is current directory.
(000021)2016.12.04 23:14:42 - guest (127.0.0.1)> TYPE I
(000021)2016.12.04 23:14:42 - guest (127.0.0.1)> 200 Type set to I
(000021)2016.12.04 23:14:42 - guest (127.0.0.1)> SIZE /
(000021)2016.12.04 23:14:42 - guest (127.0.0.1)> 550 File not found
(000021)2016.12.04 23:14:42 - guest (127.0.0.1)> CWD /
(000021)2016.12.04 23:14:42 - guest (127.0.0.1)> 250 CWD successful. "/" is current directory.
(000021)2016.12.04 23:14:42 - guest (127.0.0.1)> PASV
(000021)2016.12.04 23:14:42 - guest (127.0.0.1)> 227 Entering Passive Mode (127,0,0,1,202,87)
(000021)2016.12.04 23:14:42 - guest (127.0.0.1)> LIST -l
(000021)2016.12.04 23:14:42 - guest (127.0.0.1)> 150 Connection accepted
(000021)2016.12.04 23:14:42 - guest (127.0.0.1)> 226 Transfer OK
(000021)2016.12.04 23:14:42 - guest (127.0.0.1)> QUIT
(000021)2016.12.04 23:14:42 - guest (127.0.0.1)> 221 Goodbye
(000021)2016.12.04 23:14:42 - guest (127.0.0.1)> disconnected.


It took 22s to open ftp in browser. Every time I enter any directory I need to wait ~20s for it to load or start downloading anything.
Restarting Filezilla module in XAMPP fixes the problem.
My system specs: Win7 Pro x64, i5-2540m 2.6GHz, 4GB RAM.
Ishutaru
 
Posts: 7
Joined: 04. December 2016 21:44
XAMPP version: 5.6.28
Operating System: Windows 7 Professional

Re: Filezilla heavy lag after login spam

Postby Ishutaru » 20. January 2017 23:01

Any ideas? Long time passed, I don't think i'm the only one with this issue.
Ishutaru
 
Posts: 7
Joined: 04. December 2016 21:44
XAMPP version: 5.6.28
Operating System: Windows 7 Professional

Re: Filezilla heavy lag after login spam

Postby Nobbie » 21. January 2017 12:33

Ishutaru wrote:Any ideas?


Simply dont hit Enter many times. Maybe there is a SPAM timeout in FileZilla (i dont know). But i do not hit Enter 4 to 8 times without any need.

Ishutaru wrote: I don't think i'm the only one with this issue.


Sure? I dont think that there are many people out there hitting Enter with no password (knowing, that they have assigned a password). As already said, simply dont hit Enter many times and everything runs fine.
Nobbie
 
Posts: 9562
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests