Basic htdocs issues

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Basic htdocs issues

Postby bquatt » 25. November 2016 05:41

I recently deleted and reinstalled Apache. Afterwards I created a folder in htdocs, but it would not show up on my localhost index on the web browser (localhost/xampp). I am very new to this programming so please bare with me and my lack of understanding. Any help would be greatly appreciated.
bquatt
 
Posts: 2
Joined: 25. November 2016 05:33
XAMPP version: apache
Operating System: Windows 8

Re: Basic htdocs issues

Postby Nobbie » 25. November 2016 11:58

bquatt wrote:I recently deleted and reinstalled Apache.


What does that mean? Is it a Xampp installation? How did you install Apache and where?

bquatt wrote:Afterwards I created a folder in htdocs, but it would not show up on my localhost index on the web browser (localhost/xampp).


Why do you apply "xampp" in the URL? Your folder cannot show up as http://localhost/xampp (unless you called the folder "xampp"), it should be accessible via http://localhost/foldername (where foldername is the name of your folder). But if you simply applied an empty folder, this may fail also, you should create an index.html or index.php file at least.
Nobbie
 
Posts: 9629
Joined: 09. March 2008 13:04

Re: Basic htdocs issues

Postby bquatt » 26. November 2016 05:53

haha I am laughing at myself for how clueless I must appear. I uninstalled Apache after having some unrelated issues and then reinstalled it. I only stated that in case there are any obvious issues that may cause that anyone on the forum may know of. Yes, it is xampp and it's currently on my c: drive. localhost/xampp is how I pull up my localhost index page. Local host/foldername does not work. The tutorial I watch showed that a blank folder added to htdocs will still show up on the localhost index. I will look up how to create a php or html file. Thanks for your time.
bquatt
 
Posts: 2
Joined: 25. November 2016 05:33
XAMPP version: apache
Operating System: Windows 8

Re: Basic htdocs issues

Postby Nobbie » 26. November 2016 12:22

You must learn to describe your problems properly:

1) Xampp is a distribution of many tools (Apache is only one of these) and you cannot simply install Apache only. You also cannot de-install Apache only. Therefore, please explain precisely what you did, you did not uninstall Apache only. What exactly did you do?

2) Please use correct names, in your last posting you say "Local host/foldername", what of course cannot work, as "Local host" is unknown, it must be "localhost".

3) Never ever say "does not work". That is a totally useless bunch of words which does not help us in any way to understand, what is going wrong. The most errors are coming with a qualified error message and a certain behaviour, please provide the error message (completely!) and describe the behaviour. As long as you say "does not work", as long nobody can help you.

4) Xampp is NOT configured to show up foldernames of subfolders in htdocs (who says so??), instead if you enter http://localhost in your browser, Xampp shows up a so called "dashboard" (a kind of welcome page). It does NOT show files and filenames of htdocs. If you would like to have such behaviour (but i cannot see any use for it), you have to change some things, but "out of the box" Xampp does not behave in that way.

5) Dont trust and follow to outdatet tutorials. There are plenty of old and incorrect tutorials out there in the WWW. Instead look into the Xampp FAQ , for Windows it is https://www.apachefriends.org/faq_windows.html
Nobbie
 
Posts: 9629
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 38 guests