Problem upgrading php from 5.3.1 to 5.3.29

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem upgrading php from 5.3.1 to 5.3.29

Postby dafaher » 03. September 2016 18:07

Good morning everyone, I was wondering if you could help me. I need to recreate the web environment provided by my web hosting service to detect a problem with Joomla. The server runs Apache 2.2, MySQL 5.1.41 and PHP 5.3.29. I know it's almost obsolete, but my client doesn't want to change it until next year.
Xampp 1.7.3 has the Apache and MySQL versions I need, so I thought of installing it and updating the php version manually, replacing the folders, but nothing seems to work properly. When I try to visit phpMyAdmin it says there's a problem with mysqli libraries.
I would appreciate any suggestion to solve this problem. Thanks in advance for your help!
dafaher
 
Posts: 5
Joined: 06. August 2015 21:00
XAMPP version: 1.7.3
Operating System: Windows 10 - 32 bits

Re: Problem upgrading php from 5.3.1 to 5.3.29

Postby Nobbie » 03. September 2016 19:21

Even if you get it working, usually errors do not occure in another environment. The server environment not only uses different Apache/PHP/MySQL Versions, but also different Operating System, different Pathnames, different Users, different Rights management.

You really should debug on the production server itself, otherwise i dont think you will ever find what is going wrong. This is my personal experience in 30 years of IT development. You are simply waisting your time.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: Problem upgrading php from 5.3.1 to 5.3.29

Postby dafaher » 03. September 2016 19:27

Thank you very much for your advice, Nobbie! Debugging is the first thing I did but there was nothing wrong. Thanks again!
dafaher
 
Posts: 5
Joined: 06. August 2015 21:00
XAMPP version: 1.7.3
Operating System: Windows 10 - 32 bits

Re: Problem upgrading php from 5.3.1 to 5.3.29

Postby Nobbie » 04. September 2016 11:15

Last not least, if there is a problem with Joomla, you should write an error report to the Joomla development.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: Problem upgrading php from 5.3.1 to 5.3.29

Postby dafaher » 04. September 2016 16:24

That's a good one! Thanks again Nobbie, I will do that right now.
dafaher
 
Posts: 5
Joined: 06. August 2015 21:00
XAMPP version: 1.7.3
Operating System: Windows 10 - 32 bits


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests