Error: Apache shutdown unexpectedly, won't start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error: Apache shutdown unexpectedly, won't start

Postby Sher99 » 20. August 2016 18:31

Hello there. I uninstalled xampp on Windows 10 to reinstall and start from scratch. Prior to this the xampp control panel locked up. Below is the error I am getting after the new install.
I would sure appreciate some help getting up and running again.
Thank you!

11:16:05 AM [Apache] Error: Apache shutdown unexpectedly.
11:16:05 AM [Apache] This may be due to a blocked port, missing dependencies,
11:16:05 AM [Apache] improper privileges, a crash, or a shutdown by another method.
11:16:05 AM [Apache] Press the Logs button to view error logs and check
11:16:05 AM [Apache] the Windows Event Viewer for more clues
11:16:05 AM [Apache] If you need more help, copy and post this
11:16:05 AM [Apache] entire log window on the forums
11:20:17 AM [Apache] Problem detected!
11:20:17 AM [Apache] Port 80 in use by "Unable to open process" with PID 4!
11:20:17 AM [Apache] Apache WILL NOT start without the configured ports free!
11:20:17 AM [Apache] You need to uninstall/disable/reconfigure the blocking application
11:20:17 AM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
11:20:17 AM [Apache] Attempting to start Apache app...
Sher99
 
Posts: 4
Joined: 15. August 2016 21:02
XAMPP version: 5.6.23
Operating System: Windows 10

Re: Error: Apache shutdown unexpectedly, won't start

Postby Sher99 » 20. August 2016 18:44

I was able to fix this by changing the port to 81. :-)
Sher99
 
Posts: 4
Joined: 15. August 2016 21:02
XAMPP version: 5.6.23
Operating System: Windows 10

Re: Error: Apache shutdown unexpectedly, won't start

Postby success65 » 04. September 2016 02:16

How did you change the port number? Can you let me know also? Thank you
success65
 
Posts: 1
Joined: 01. September 2016 22:25
XAMPP version: v3.2.2
Operating System: Windows 8.1

Re: Error: Apache shutdown unexpectedly, won't start

Postby Nobbie » 04. September 2016 11:19

Dont change the port number, that is not recommended. Google will find tons of hints if you enter " Port 80 in use by "Unable to open process" with PID 4!". It will point to Microsoft IIS which comes with some Windows installations (Ultimate Edition etc.), that is Microsofts Webserver (which actually does the same job as Apache) and it already takes Port 80. Instead of changing Apache Port, at least stop (or even better, de-install it) the Internet Services. Google will help you. And then run Apache on Port 80, as Port 80 is the default Port for HTTP.
Nobbie
 
Posts: 8775
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 70 guests